Generic NEC USB3.0 PCIe Installation problems

Discussion in 'Mac Pro' started by TomTomTuning, Nov 2, 2012.

  1. TomTomTuning, Nov 2, 2012
    Last edited: Nov 2, 2012

    macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #1
    Hey everyone, I'm having a heck of a time trying to install a NEC USB3.0 PCIe card. I'm running Mountain Lion.

    Here's the card I purchased (screenshot): http://i9.photobucket.com/albums/a98/boostd240/Misc/MAC-PRO-USB30NEC.jpeg
    I dont have the molex power adapter connected, from what I've read it's not required on a Mac Pro. Is this true?

    The device I'm trying to use a WD MyBook 2TB USB3.0
    Works fine in my USB2.0 ports.

    I've tried a few .kext files but no luck. The furthest I've gotten was when following this tutorial: http://forums.macrumors.com/showthread.php?t=1238494 The only .kext that shows up in the USB System Information is the old one from this thread. Newer .kext dont seem to work. By the way I had to use Kext Wizard because Kext Helper wouldnt download.

    Here's a screen shot of my System Info, the WD drive is plugged in but isnt working.
    And AHCI Controller is my ASM1061 eSata/Sata card.

    [​IMG]

    I would love to try another USB3.0 device but I dont have one at the moment.
    Any suggestions is super appreciated. :)
     
  2. thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #2
    Umm I read somewhere that the Lacie cards perviously only supported Lacie drives only. I wonder since I'm using what I believe are older Lacie drivers, this is the reason my WD MyBook drive isn't working?

    I'm starting to think the "cheap" generic card was not worth the headaches. I should have gone with a Lacie or Caldigit card. :confused:
     
  3. thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #3
    Here's the modified Lacie .kext I've tried.
    http://www.osx86.net/downloads.php?do=file&id=2870

    - 10.0.8 .kext shows up in USB sys-info just fine (still doesn't work though)

    - When I try 10.0.10 it doesn't show up anymore and when I use Kext Wizard to view the loaded .Kext files, it doesn't show the PXHCD anymore (it did with 10.0.8).
     
  4. thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #4
    Can someone confirm, do I need to connect the card to a power source?

    If so It appears there's two PCIe power connections on the main logicboard, one is being used by my graphic card, can I use the other to power the USB3.0 PCIe card? I'll just need a PCIe -to- Molex adapter.
     
  5. thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #5
    Sold the generic card to a PC friend and ordered a Lacie card, it will be here today. :)
     
  6. macrumors member

    Joined:
    Jul 18, 2012
    #6
    Hi,

    Our cards are not exclusive to LaCie products. When USB 3.0 first came out, most manufacturers had to write their own drivers for OSX since Apple didn't include drivers until recently.

    Our cards will mount any USB 2.0 or 3.0 device that is supported by the OS but unless its a LaCie its only guarantee'd to work at USB 2.0 - due to the proprietary drivers.

    ~mn, LaCie
     
  7. TomTomTuning, Nov 6, 2012
    Last edited: Nov 7, 2012

    thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #7
    Thanks for your reply.

    I've installed the official Lacie USB3.0 PCIe card and the latest drivers (1.0.11) but i'm having a few problems.

    - My 2TB WD MyBook external USB3.0 drive isn't mounting.
    Although a unpowered 2.5" USB2.0 drive works fine.
    Is there a list or any way to determine what USB3.0 devices do not work with this Lacie Card?

    - My Magic Mouse is going crazy, lags horribly and occasionally disconnects and reconnects.

    - After running the Uninstaller, my Finder sidebar gets messed up and disappears, the only way I've found to get it working again is to run Onyx. Repairing the Permissions on it's own did not solve the problem.

    Any help is appreciated.
     
  8. thread starter macrumors regular

    Joined:
    Oct 21, 2010
    Location:
    Central PA
    #8
  9. macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #9
  10. macrumors 6502

    ender78

    Joined:
    Jan 9, 2005
    #10
  11. macrumors 603

    VirtualRain

    Joined:
    Aug 1, 2008
    Location:
    Vancouver, BC
    #11
    100MB/s on my external drive, but that's limited by the drive, not the card.
     

Share This Page