Genius Problems

Discussion in 'iPod' started by supermac1, Sep 9, 2009.

  1. supermac1
    Expand Collapse
    macrumors regular

    Joined:
    Jun 22, 2009
    #1
    When i try to turn on genius and upload my info to itunes, it keeps saying there is a connection problem with itunes. Anyone else having this problem?
     
  2. Surely
    Expand Collapse
    Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #2
    I didn't have that problem, but if everyone is trying to connect at the same time, it wouldn't surprise me if Apple's servers are overloaded.
     
  3. supermac1
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Jun 22, 2009
    #3
    Ugh. I just tried it on my sisters computer and it worked quickly. Now i dont know what to do.
     
  4. Surely
    Expand Collapse
    Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #4
    Try quitting iTunes and restarting it. Then try Genius again.
     
  5. supermac1
    Expand Collapse
    thread starter macrumors regular

    Joined:
    Jun 22, 2009
    #5
    Tried several times. Doesn’t help.
     
  6. tylerscottd
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 17, 2006
  7. ipedro
    Expand Collapse
    macrumors 68030

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #7
    I have the same issue. I quit iTunes, restarted the Mac, went through the process of turning off the Genius and then turning it back on... I still get the message:

    We could not complete your iTunes Store request.
    The network connection was lost.
     
  8. ipedro
    Expand Collapse
    macrumors 68030

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #8
    Found a Solution

    I found a fix.

    Quit iTunes, then Delete the iTunes Library Genius.itdb file in the parent iTunes folder.

    When you go back into iTunes, follow the regular procedure to enable Genius and it works.
     
  9. tylerscottd
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 17, 2006
    #9
    Just tried this, unfortunately still doesn’t seem to be working for me :confused:
     
  10. ipedro
    Expand Collapse
    macrumors 68030

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #10
    Yeah, false alarm :(

    What it did was allow iTunes to gather information about your library which delayed the error message for a while. The problem happens when iTunes tries to send the results to Apple.

    I'm calling AppleCare in the morning to troubleshoot this.
     
  11. tylerscottd
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 17, 2006
    #11
    Report back with what they say, if you don’t mind? :eek:
     
  12. ipedro
    Expand Collapse
    macrumors 68030

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #12
    Now I Fixed It!

    Damn it! That was a tough cookie to crack!

    Cookies!! Quit iTunes then go to your /user/library folder and move the Cookies folder to the desktop or delete it.

    Turn on Genius. It works!

    There must be some weird setting saved in cookies with an incorrect URL to send the info to Apple.
     
  13. tylerscottd
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 17, 2006
    #13
    Finally! It works

    Although I noticed that if I had Safari open while I did this it didn’t seem to have an effect (might just be something with my Mac though)
     
  14. cosmokanga2
    Expand Collapse
    macrumors 6502a

    cosmokanga2

    Joined:
    Jan 7, 2008
    Location:
    Canada, where we live in igloos.
    #14
    Works! Thanks a zillion.
     
  15. pardthemonster
    Expand Collapse
    macrumors newbie

    Joined:
    Aug 1, 2005
    #15
    You could have found this solution at Apple's Discussion Board quicker: http://discussions.apple.com/message.jspa?messageID=10167163#10167163
     
  16. ricfactor
    Expand Collapse
    macrumors newbie

    Joined:
    Oct 10, 2009
    #16
    Don't blow away all your cookies

    If you don't want to blow away all of your cookies, just open Safari's preferences, and under the Security tab click the Show Cookies button. Search iTune and remove that cookie. This worked for me.
     

Share This Page