Getting an mpg to play on my iPod (Details inside)

Discussion in 'iPod' started by mikemodena, Oct 30, 2005.

  1. macrumors 6502a

    mikemodena

    Joined:
    May 30, 2005
    Location:
    Connecticut
    #1
    Hey everyone.. I have a couple .mpg video files of some live bands that I would like to play on my ipod at m4v. I downloaded MovieToGo which did convert it to m4v but without audio. I tried it in Compressor and it gave me the error, "Cannot convert mpeg 1 or 2 audio." Is there a program that will allow me to convert this mpg to a m4v. Is it possible to do it in such a way to go from mpg to mp4 then to m4v? Will mp4 play on an iPod or only m4v?
     
  2. macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #2
    Did you try ffmpegx? Run it and use the PSP settings to produce video (with sound) that should play correctly on an iPod.
     
  3. thread starter macrumors 6502a

    mikemodena

    Joined:
    May 30, 2005
    Location:
    Connecticut
    #3
    Downloading right now.. will post with results. Thanks, clayj!
     
  4. iDM
    macrumors 6502a

    iDM

    Joined:
    Jul 6, 2005
    Location:
    The Commonwealth of PA/The First State-DE
    #4
    Hey clayj any idea you could explain the PSP settings exactly cause when i try to use them, i either get a failed message as soon as i begin the encoding or i get a file that is zero kb big. I outline my extensive video problems on this thread. You will officially become the most helpful person in the world if you can help. http://forums.macrumors.com/showthread.php?p=1867883#post1867883
     
  5. thread starter macrumors 6502a

    mikemodena

    Joined:
    May 30, 2005
    Location:
    Connecticut
    #5
    Didn't work.. it's not recognizing .mpg as having audio.. :(
     
  6. iDM
    macrumors 6502a

    iDM

    Joined:
    Jul 6, 2005
    Location:
    The Commonwealth of PA/The First State-DE
    #6
    I have had nothing but problems with FFMPEGX and i have been posting on every single iPod video thread trying to get this figured out, good luck and please let me know if you can get it working.
     

Share This Page