Getting better Divx playback on old macintosh

Discussion in 'Mac Apps and Mac App Store' started by 7on, Sep 17, 2005.

  1. 7on macrumors 601


    Nov 9, 2003
    Dress Rosa
    Is there a way to get smooth playback on a 400mhz G3 Blue and White running the latest Tiger?

    400Mhz G3
    256MB of RAM
    ATI Rage w/ 16MB VRAM

    I know most will say "UPGRADE THE RAM!!!" but is that really the bottleneck? I'd figure maybe the proc might be? Any real world examples of more ram = smooth DIVX playback? And I'm talking about 30FPS here, I don't want to upgrade to 1 GB or whatever and playback hovering around 20-30.

    Otherwise I wouldn't upgrade the RAM. Though I would eventually need TV output if I go this route.

  2. mike.b macrumors newbie


    Sep 16, 2005
    Romania, Europe
    Use mplayerosx, and in the preferences, enable the option "drop frames on slower machines" You should see some improvements.
  3. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I seriously doubt you're going to get full 30fps playback from anything but a very small DivX video with a 400MHz G3 no matter how much RAM you have. Trying MPlayer or VLC might get you a few more FPS, but that speed of G3 just isn't capable of doing the processing to play the latest video codecs.

    An extra 256MB would definitely improve the performance of your computer, but it's not going to help much (if at all, depending on what else is running at the time) with video playback. 512MB and 1GB probably won't even be noticeable unless you're using QT Pro to buffer the entire video to RAM, and even then your processor will still be the bottleneck.

    This is an extreme example, but keep in mind that something around a 2.0GHz G5 is required to play the largest high defintion h.264 videos smoothly.
  4. 7on thread starter macrumors 601


    Nov 9, 2003
    Dress Rosa
  5. motulist macrumors 68040


    Dec 2, 2003
    Here are the speed up tricks I know of. They might work, they might do nothing.

    0) Quit all programs except the video player and close all finder windows.

    1) Go to the energy saver control panel and set your processor, disk, and everything settings to highest.

    2) Depending on your video card, try using aticcelerator and overclocking your video card.

    3) launch the video app you use. Then go to the terminal and type "top" and a list will come up. In front of the video player's name there'll be a number. Copy that number. Now open a new terminal window and type "sudo renice -20 ####" where #### is the number you just copied. It will ask for your password, put it in and Then quit terminal.

Share This Page