Getting rid of the App Store notifications

Discussion in 'OS X Mountain Lion (10.8)' started by iRock1, Apr 5, 2013.

  1. iRock1
    Expand Collapse
    macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #1
    Sometimes I see on my desktop an annoying notification indicating me that there is an update available in the App Store. The problem is that I can't get rid of this popup without clicking it and actually going to the App Store to update my system.

    This behaviour seems completely absurd. If I don't want to update OS X in that moment, how can I send that little and annoying warning away?

    Cheers! :apple:
     
  2. justperry, Apr 5, 2013
    Last edited: Apr 6, 2013

    justperry
    Expand Collapse
    macrumors 603

    justperry

    #2
    You can find the settings in System Preferences, Software Update.

    Edit: Removed screenshot
     
  3. iRock1
    Expand Collapse
    thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #3
    But actually I want it to download the updates in the background. What I don't want are those annoying pop-ups.


    Sent from my iPhone using Tapatalk 2
     
  4. Chundles
    Expand Collapse
    macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
  5. justperry
    Expand Collapse
    macrumors 603

    justperry

    #5
    I don't get any messages at all.
     
  6. treichert
    Expand Collapse
    macrumors 6502

    Joined:
    Nov 7, 2007
    Location:
    Aachen, Germany
    #6
    In System Preferences, go to Notification Center, select AppStore on the left and turn off it's Notifications.
     
  7. iRock1
    Expand Collapse
    thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #7
    That's the first thing that I tried, but it's not there.


    Sent from my iPhone using Tapatalk 2
     
  8. treichert
    Expand Collapse
    macrumors 6502

    Joined:
    Nov 7, 2007
    Location:
    Aachen, Germany
    #8
    Hm, that's strange. I just checked it as well, and it's gone for me too.

    Maybe I'm mixing this up with one of the Mountain Lion betas, but I'm quite certain, that this was there in 10.8.0.

    Maybe they removed it, so users wouldn't ignore security updates. :confused:
     
  9. iRock1
    Expand Collapse
    thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #9
    It would be great if I could fix it with a line in Terminal or something. There must be an option.


    Sent from my iPhone using Tapatalk 2
     
  10. davidlv
    Expand Collapse
    macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #10
    Disable Notifications Center
    sudo defaults write /System/Library/LaunchAgents/com.apple.notificationcenterui KeepAlive -bool false
     
  11. iRock1
    Expand Collapse
    thread starter macrumors 6502a

    iRock1

    Joined:
    Apr 23, 2011
    #11
    I don't want to disable NC actually, only the App Store pop-ups.


    Sent from my iPhone using Tapatalk 2
     

Share This Page