Getting the most out of WoW

Discussion in 'Games' started by iindigo, Sep 20, 2005.

  1. iindigo macrumors 6502a

    iindigo

    Joined:
    Jul 22, 2002
    Location:
    San Francisco, CA
    #1
    Hey guys!

    I was recently sucked into the whirlpool known as World of Warcraft, and I was wondering if there were any good ways to boost its framerate without losing detail. I'm running it on a 2Ghz 20" iMac G5 w/128MB ATI Radeon 9600 and 2GB of RAM, yet I only get about 10fps on average. WoW is set to max settings.

    Am I expecting too much of my hardware? I really don't want to turn down the graphics.
     
  2. patseguin macrumors 65816

    patseguin

    Joined:
    Aug 28, 2003
    #2
    Turn down the draw distance. You won't notice much visually and it will improve frame rates significantly.
     
  3. huck500 macrumors 6502

    huck500

    Joined:
    May 10, 2004
    Location:
    Southern California
    #3
    You are expecting WAY to much from your hardware...or maybe from Blizz's Mac optimization team...

    Turn down your draw distance for a huge improvement. I have it set all the way down and it's inconvenient but I'm used to it.


     
  4. beige matchbox macrumors 6502a

    beige matchbox

    Joined:
    Mar 16, 2005
    Location:
    Oxfordshire, UK
    #4
    Put terrain distance and environment detail to the middle. The draw distance isn't noticeable when playing, and the environment detail is only a slight annoyance. Make sure Level of detail is ticked, this helps a fair bit

    also turn down, or off the anisotropic filtering, this is a massive hog. Similarly try 2x or 4x multisampling, both dont make a huge impact on looks, but massively slow the game down :)


    Doing that should get you a pretty playable game :D
     
  5. Dr. Dastardly macrumors 65816

    Dr. Dastardly

    Joined:
    Jun 26, 2004
    Location:
    I live in a giant bucket!
    #5
    When I use to play it I had just about everything set to low. Made the game run smooth as silk on my 15" PB 1.5ghz SD. After a couple minutes (really just a couple) you wont even notice it. I switched the settings back but found that the graphics weren't even that much of a difference to warrant a such a trade off in speed.

    I would say just try it for an hour with the graphics settings on low and see how that works. Especially the draw distance.
     
  6. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #6
    I agree, turn down the Terrain Distance setting. Also check (select) Level of Detail. My other settings are:

    Environmental Detail: medium
    Anisotropic Filtering: low
    Terrain Texture: low
    Texture Detail: high

    Shader boxes selected: Enable All, Terrain Highlights, Vertex Anim. Shaders
    Misc. boxes selected: Trilinear Filt., Vertical Sync, Hardware cursor

    With these settings, on a dual 2.0 G5, Radeon 9600 Pro 64 MB, 1.5 GB RAM, at 1280x960 resolution, I get about 25-40 fps. Occasionally it will drop below 20 fps with a huge amount of stuff going on, but rarely. Even though I have dual CPUs, they only get taxed to a maximum of perhaps 60% each. You ought to be able to do better than 10 fps on your rig. However, your native screen resolution is 1680x1050, about 40% more pixels than I'm showing. You might try dropping your screen resolution down (try 1/2 res at 840x525)...although this sucks on an LCD because it's going to look soft and kind of crappy by comparison.
     
  7. Macamus Prime macrumors regular

    Joined:
    Feb 24, 2005
    Location:
    NYC
    #7
    Start by toning down the settings!

    I agree with the draw distance, no need for it to be so far.
     
  8. shortyjj macrumors regular

    Joined:
    Apr 21, 2004
    #8
    As someone who has only ever played it on a 12" screen with most stuff disabled, am I missing much? Is it worth it to finally put a decent video card in my gfriend's PC and hook it up to the 20" monitor?

    At the very least, I could bask in the visual glory that is my 53 NE druid...
     
  9. Soulstorm macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #9
    turn off FSAA. Set it to OFF.

    This will dramatically improve performance.

    btw, I have played with my G5 (see below) the wow while it was still in beta, and it reached 30 fps! How is it possible that your setup only reaches 10?
     

Share This Page