1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Getting the worms off my external usb drive???

Discussion in 'Windows, Linux & Others on the Mac' started by lopro, Mar 12, 2009.

  1. macrumors newbie

    #1
    I have a Western Digital 500gb "My Book". I use it with my MacBook running Win XP Professional (via Parallels) and Mac OS X v10.5.6. Usually works, no problem, until recently:

    I wanted to save data from my Mac OS partition to the usb ext hard drive. I mounted the external drive. I created a new folder on the ext hard drive. I clicked and dragged. Then I get an error about "I/O error - write failed". Then I noticed an autorun.inf on my usb hard drive and a host.exe. I researched and saw that these are worms/virus. I tried several times to delete those files, and was finally successful. I also noticed that the folder I had just created to save data, would not delete. I also noticed a folder called "System Volume Information" and many sub folders, which would not delete.

    Since then, my external hard drive acts weird. On Windows, it freezes the operating system for long periods and will not open to reveal folders. I ran AVG Free on it in Windows, which discovered nothing. I ran a few others (usb firewall, flash disinfector) and they do not discover anything malicious on this external drive. If I disconnect the external hard drive, everything runs smoothly.

    On Mac OS X, the ext drive mounts and opens, but my permissions are set to custom and I cannot change this (no check boxes visible). Plus the .mp3 files on this external hard drive cannot open (meaning they are not default to iTunes & using ctrl-click "open with" still will not let me select iTunes because its grayed out). It also looks like some of my data is missing from folders.

    I can see most of the data on this external hard drive, but what should I do to stabilize the external drive so I can get my precious data off and breathe again? I'm dazed and confused.

    Thanks for any support & for the stamina to read such a long post...
     
  2. Moderator

    yellow

    Staff Member

    #2
    I/O error typically indicates a hardware problem with either the hard drive or the enclosure (or if you're really lucky, the cable), not a software or malware problem.

    After all, it's a Western Digital drive. It was (imo) destined to fail as soon as you took it out of the box.

    And since I assume that it's a FAT32 drive (or are you using MacFUSE?), permissions don't mean diddly on the drive.
     
  3. macrumors newbie

    #3
    my apologies...it's not an I/O error it says:

    "Sorry, the operation could not be completed because an unexpected error occurred. (Error code - 1407)"
     
  4. Moderator

    yellow

    Staff Member

    #4
    What format is the drive?
     
  5. macrumors newbie

    #5
    NTFS is the format...
     
  6. Moderator

    yellow

    Staff Member

    #6
    Mac OS X cannot natively write to NTFS, therefore you cannot delete folders, which is effectively writing to the filesystem. You must have MacFUSE installed?

    Any filesystem work must be done from Windows, not Mac OS X. You should probably invest in some Windows disk utilities and/or file recovery tools to try and save your data.
     
  7. macrumors newbie

    #7
    Yeah...I do have MacFuse & NTFS-3G. But that drive is still acting erratically. When I try to copy files from it to my "clean" storage device, the files on the affected external hard drive start to delete themselves. I was able to get some of my data off, but other data appears to be gone from this faulty external drive.

    SO now, I've installed Migo's Recover Lost Data on Win XP and was hoping to go that way. Only problem is that the program cannot see my faulty drive. When I plug the drive into my Win XP environment, it locks the operating system up for long periods of time, and the drive just does not open in Windows...
     

Share This Page