Gmail IMAP problems?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TonySwartz, Nov 22, 2007.

  1. macrumors member

    Jan 11, 2004
    I've set up Gmail according to their instructions, enabled IMAP on my account, etc etc - almost every time I ask it to check for mail, I get:

    "Cannot Get Mail
    The connection to the server "(null)" failed."

    A couple times a day it will pull mail correctly, but most of the time I get this message. It's also done weird things like when I type a new message (either on the iPhone OR in Mail), it "sends" but then is nonexistent in my sent box on the phone/Mail and in Gmail. The message never actually sends...but I get a message saying it sent.

    Is anyone else having weird problems like this? Any solutions?
  2. macrumors 68040


    Jun 6, 2007
    Cheshire, United Kingdom.
    These are the settings for Gmail on my iPhone, and they work perfectly:
    Incoming Server:
    User Name:******
    Password: ********

    Outgoing Server:
    User Name: *******
    Password: ********

    Then, under the advanced settings:

    Incoming Settings
    Use SSL: ON
    Authentication: Password
    Server Port: 993

    Outgoing Settings
    Use SSL: ON
    Authentication: Password
    Server Port: 587

    Hope this helps. :)
  3. macrumors 6502a

    Oct 21, 2007
    Glasgow, UK
    I use the same settings and all works perfect here too.
  4. thread starter macrumors member

    Jan 11, 2004
    #4 settings are identical.

    For what it's worth, I just deleted the account, changed my password with Google (it was pretty short - back before the required a certain number of characters), and it works fine. Could have been the password length...?
  5. macrumors 6502

    Jun 14, 2004
    I've been having tons of issues, really pissing me off. Now all of a sudden, none of my email accounts work. Not receiving or sending, ugh...
  6. macrumors regular

    Jun 30, 2007

    One of my old accounts wasn't working either (same symptoms). It also had a very short password from when they didnt force longer. I just reset the password like you did, and its working just fine like
    y primary gmail on iPhone IMAP has for weeks.

    Strange, but thanks for the suggesstion. Seemed to do the trick.
  7. macrumors 6502a


    May 25, 2005
    That's unacceptable! Ask Google for your money back.
  8. macrumors member

    Aug 10, 2007
    Gmail Freezes iPhone

    I have forwarded my 3 POP accounts to one Gmail on the iPhone. Messages come superquick and no reloading of images or pdfs everytime. The only problem is the phone freezes most everytime after navigating through my account.
  9. macrumors newbie

    Apr 22, 2008
    Gmail uses TLS outgoing. SSL doesn't seem to work.
  10. macrumors newbie

    Jun 14, 2008
    I was having the same problem

    This was happening to me since yesterday. I finally just turned my phone off, turned it back on and it's working fine.

    In addition to finally getting my email, I also got a bunch of voicemails and text messages that hadn't come through.

    I'd suggest just turning the phone off and back on before resorting to deleting your account and then having to set it up again.
  11. macrumors member

    Dec 5, 2003
    Saint Paul, MN
    Both my Gmail and .Mac accounts do this frustrating thing where I will read the message, it will get marked as read on the Phone, but then a few minutes later, the Phone again shows that I have unread messages, but it's the same messages I already read. I suspect it is an issue with how the iPhone processes IMAP messages.
  12. macrumors newbie

    Oct 10, 2008
  13. macrumors 6502a

    Jun 23, 2007
    I been trying to get gmail working on my GF's iPhone and was having issues. A quick google search led me to this thread. Clearing the CAPTCHA did the trick!

Share This Page