gmail "Password Incorrect" in Imap, Push, Inconsistently!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by whyrichard, Apr 25, 2010.

  1. macrumors 68000

    Joined:
    Aug 15, 2002
    #1
    Hey,

    I am having repeated and seemingly inconsistent (though currently consistently) problems with gmail saying my password is incorrect. It's not. I tried this with push, and then resorted back to imap (with gpush app) and it now won't accept my password with imap at all.

    Gmail is not working with my iphone at all!

    What is the problem here? in the past two months gmail and my iphone don't play together well at all anymore!

    r.
     
  2. macrumors member

    Joined:
    Apr 19, 2010
    Location:
    Waco, TX
    #2
    Delete the Gmail account from your iPhone, then hold down the home button and power button till you see the Apple logo (this will cause a full restart of the phone, it will NOT erase anything).

    Then add back the Gmail account and see if that works.
     
  3. thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #3
    Thanks but no dice. Says incorrect password.

    Is there a link where once types in the letters in a wonky image to make sure there are no bots?

    Do i have to change my password?

    r.
     
  4. thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #4
    i changed my gmail password in google accounts and still, no gmail to iphone.

    r.
     
  5. thread starter macrumors 68000

    Joined:
    Aug 15, 2002
    #5
    and specifically, it says that my imap.gmail.com password is incorrect...


    no help?

    hmmmmm.

    r.
     
  6. macrumors newbie

    Joined:
    Jul 19, 2007
    #6
    I just ran into the same issue. Were you able to resolve it?
     
  7. macrumors 65816

    Joined:
    Dec 13, 2009
    #7
  8. macrumors newbie

    Joined:
    Mar 17, 2009
    #8
    I had the same problem. Go to gmail on your computer and log in. You'll have to type in numbers in a box. Apparently there is some deal where they make you re-verify your account. After that, no further problems.
     
  9. macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #9
    yup - i think they have some sort of spam/access control. This usually works for me (but it is still a nuisance.)
     
  10. macrumors 65816

    Joined:
    Apr 19, 2004
    #10
    I just ran into this same problem. I got my iPhone replaced. Did a restore from a backup to my new one and one particular gmail account refused to work.

    I finally solved it by logging into gmail website.
    Going to the settings.
    DISABLING imap (as it was already enabled before).
    Saving.
    Going back to the settings.
    ENABLING imap (very counter intuitive)
    Saving.
    Trying again on my iPhone and it worked!



    It drove me crazy cause every site says you must enable imap, well wtf do you do if it's already enabled? Answer: disable it, then enable again lol
     
  11. macrumors newbie

    Joined:
    Sep 3, 2010
    #11
    Solution to gmail password problems on iPad

    I am not sure why or when, but gmail must have made some type of change to their system and you probably just need to unlock CAPTCHA in order to get this working again. YOU MUST DO THIS FROM THE IPAD. Go to this site and follow the instructions.

    http://mail.google.com/support/bin/answer.py?hl=en&answer=14257
     
  12. MUA
    macrumors newbie

    Joined:
    Jan 18, 2011
    #12
    iPhone GMAIL PASSWORD TROUBLE

    Registered to leave this one-time post to tell everyone that this is the only suggestion that worked to get my Gmail functioning properly on my iPhone--access the page from the browser on your iPhone and complete, add your accounts again, good as new:

    http://mail.google.com/support/bin/answer.py?hl=en&answer=14257
     
  13. macrumors newbie

    Joined:
    Jul 19, 2009
    #13
    Worked for me!

    This worked for me. I just logged into my Gmail account on my MacBook Pro, disabled IMAP, then re-enabled it. Then my Gmail acct started working again on my iPhone.

    Thanks for the solution! :)
     
  14. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #14
    Nothing is working for me.....I am getting the same error on my iPhone, iPad, and Mac Mail. This is making me crazy! I am really getting ready to just stop using gmail and just switch completely to me.com.

    Seems like since google starting making crappy phones they stopped caring about everything else....google search is going to crap, now mail!!
     
  15. macrumors 6502

    Joined:
    Jun 11, 2009
    #15
    Try unlocking the account here:
    https://www.google.com/accounts/DisplayUnlockCaptcha

    That worked for me.
     
  16. macrumors 65816

    mikelegacy

    Joined:
    Dec 5, 2010
    Location:
    Pittsburgh, PA
    #16
    Is your gmail setup via MS Exchange?
     
  17. macrumors newbie

    Joined:
    Sep 28, 2011
    #17
    this worked for me

    Hi there,
    my issue seemed to be a weak password. My ipad stopped working all of a sudden, and gave the incorrect password for imap.gmail.com error message.

    I tried resetting it, deleting and re-creating the account etc ( i use a Google Apps account with my own domain btw ).

    I logged into my google apps dashboard and went to the change email password section ( in plain gmail this is probably somewhere different ).

    I then tried to change the password to the one i had, but changed 1 digit. It wouldn't allow it on the basis of a 'weak password'.

    So I changed it to something a bit more complex, and hey presto, the ipad is working again now.

    so if you've tried it all with no luck - then try the above.

    cheers
     
  18. macrumors newbie

    Joined:
    Jan 7, 2012
    Location:
    Lyon, France
    #18
  19. macrumors newbie

    Joined:
    Nov 7, 2008
    #19
    2 step verification

    I turned off 2 step verification and it worked fine for me after that.
     
  20. macrumors newbie

    Joined:
    Oct 20, 2011
    #20
    gmail password fix

    I had to go here for help since I have 2 step verification turned and none of the above worked for me.

    https://accounts.google.com/b/0/IssuedAuthSubTokens


    Then generate an application specific pass and put in the settings on your iphone for your gmail account ...yes it is a totally different password but it worked.
     
  21. macrumors demi-god

    Joined:
    Oct 14, 2005
    Location:
    Virginia Beach
    #21
  22. macrumors newbie

    Joined:
    May 10, 2012
    #22
    A fix

    Hi there,

    Google in the UK is migrating @googlemail.com email addresses to @gmail.com. This is voluntary.

    But, if you're trying to set up an @gmail.com email account on your iPad, you need to log in via web and tick the box to migrate.

    Otherwise, UK users need to set up an @googlemail.com account on their iPad.

    Peace
     
  23. macrumors newbie

    Joined:
    May 19, 2012
    #23
    Solved!

    I finally figured this out. I think Google defaults accounts to having a 2-Step password type system. It's crazy because it doesn't work well on the iPhone.

    Here's what I did and it worked after I tried everything else in this thread:

    Go to Gmail Settings
    Click on the Accounts and Import tab
    Under "Change Account Settings" click on "Other Google Account Settings."
    Click on "Security" in the left column
    Turn OFF "2-Step Verification."

    This worked for me and hopefully will for you as well. I believe, once you have your gmail set up on your iOS device, you'll be able to turn 2-Step Verification again, but I haven't tried that. Not sure of the consequences for leaving it off. Use at your own risk.

    Hope this helps.
     
  24. macrumors newbie

    Joined:
    May 28, 2012
    #24
    iPhone Gmail fix

    I have my Gmail as my default email on my iphone. I had the same problem where all of a sudden I couldn't access my emails anymore. It kept saying wrong passowrd or incorrect username, even though it was the same as usual and I hadn't changed anything.

    The solution!!! While signed in to your Gmail on your computer click on the link below. Then click on the Continue button on this webpage.
    https://accounts.google.com/UnlockCaptcha

    It doesn't look like it's done anything but...
    Then try downloading your emails on your phone again. It works! I don't know how, it just does.
     
  25. macrumors newbie

    Joined:
    Jun 8, 2012
    #25
    It has to do with 2-step verification. You have to go into your security settings and authorize your iPhone to access your Gmail account. You have to access Gmail directly on the web, go to your account and go to security. Get a password for your iPhone and put into your mail setup. You have to do this because Mail can't request the additional verification from Google.
     

Share This Page