Gmail username & password are incorrect on 3G only

Discussion in 'iPhone Tips, Help and Troubleshooting' started by patp, Feb 14, 2011.

  1. Guest

    Joined:
    Apr 10, 2008
    #1
    Weird thing happened today. When I'm using 3G on my Verizon iPhone 4, when i try to download mail from my gmail account i keep getting an error: username or password is incorrect for gmail account.

    Got home and onto my own wifi and everything was fine, no more errors. I logged into my gmail account and all seems to be okay.

    Maybe a temporary glitch while searching for the gmail server thru Verizons network?
     
  2. macrumors newbie

    Joined:
    Jan 10, 2008
    Location:
    Kansas City 'Burbs
    #2
    I'm suddenly having the same issue, starting about the same time, but it's with my 3Gs on AT&T.

    Logging into gmail.com, everything works fine, but phone keeps giving me the error message.
     
  3. macrumors 6502

    briansolomon

    Joined:
    Apr 1, 2005
    Location:
    Murfreesboro, TN
    #3
    I have that happen from time to time. It clears itself up in a few hours. I can't figure it out either.
     
  4. macrumors newbie

    Joined:
    Jul 19, 2009
    #4
    Here's the fix...at least for me and a few other

    Kudos to psingh01 for posting this solution in a different thread.

    I, too, kept getting the "User name or password is incorrect" message when on the 3G network, but worked fine on Wifi.

    I did the following from my laptop, but this may work from the iOS device, too.

    -Just log in to your Gmail account.

    -Under "Settings," disable IMAP. Save it. Then go back to "Settings" and re-enable IMAP.

    Worked for me.
     

Share This Page