godaddy smtp and iphone?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by treacle, Jun 29, 2007.

  1. macrumors newbie

    Joined:
    Jul 19, 2002
    Location:
    metro New York area
    #1
    I can't seem to get my godaddy outgoing email to work on my iphone. I know I have the right settings and password though I don't see any way to change ports on the iphone and godaddy setup says to change port to 80.

    FYI It does work for POP for my godaddy account and my .mac and gmail accounts are working fine.

    Thanks in advance.
     
  2. thread starter macrumors newbie

    Joined:
    Jul 19, 2002
    Location:
    metro New York area
    #2
    anyone solve this?

    anyone? someone else here must have godaddy email?
     
  3. thread starter macrumors newbie

    Joined:
    Jul 19, 2002
    Location:
    metro New York area
    #3
    answered it myself

    for anyone else that needs this info put :80 after the outgoing server
    smtp.secureserver.net:80
    turn ssl off
    works now!
     
  4. macrumors newbie

    Joined:
    Jun 30, 2007
    #4
    I tried all that and it didn't work for me, I eventually saw that we can use cwmx.com:25 and that worked for me.
     
  5. macrumors newbie

    Joined:
    Jun 25, 2007
    #5
    Same problem with Comcast

    If you are outside their network and try to use them for outgoing mail, they kick it back. They suggest using port 587 rather than the default 25, but I haven't been able to get that to work.

    cwmx.com is AT&T's smtp server -- it will work if you are using EDGE, because that is an AT&T service, but note that it will not work whenever the iPhone switches to wifi.

    Until a better solution comes along I'm emailing from my gmail account.
     
  6. macrumors newbie

    Joined:
    Jun 30, 2007
    #6
    Yeah, I don't have any wifi spots here so I have to use Edge, fine by me, haven't had any issues with it yet.
     
  7. thread starter macrumors newbie

    Joined:
    Jul 19, 2002
    Location:
    metro New York area
    #7
    Have you enabled smtp relay on you go daddy email management page? Try that.

     
  8. macrumors newbie

    Joined:
    Jul 1, 2007
    #8
    I have the free godaddy email account, would I need to buy smtp relays? I tried to do the relay thing but didn't see it except need to by more smtp relays?
     
  9. macrumors newbie

    Joined:
    Jun 22, 2007
    #9
    Solution

    I was having the same problem but i eventually fixed it. The solution was as easy as changing the outgoing server to mail.secureserver.net (as apposed to SMTP.secureserver.net).
     
  10. macrumors newbie

    Joined:
    Jul 10, 2007
    #10
    Actually, the Go Daddy SMTP server is smtpout.secureserver.net.

    Depending on your ISP, you may need to specify a port other than the default SMTP port of 25. Try 80, as treacle suggests, or port 3535.

    Regarding the use of cwmx.com:25, that is a Cingular Wireless server, not the Go Daddy email server. It's possible that won't really matter, but it could have an impact on your ability to send to any server configured to look for SPF records. Info on SPF records can be found on their site: http://www.openspf.org/Introduction. Like I said, it may have zero impact on you, but it's something to be aware of if you end up going with cwmx.com:25.
     
  11. macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #11
    Same issue

    I have tried all the ports mentioned here on the outgoing server to no avail. The cvmx.com thing also does not work for me. Do I need to turn off the WIFI to get that to work if i am within range of my home router? Does that then force it to use the Edge network?

    Thanks
     
  12. macrumors newbie

    Joined:
    Dec 12, 2002
    Location:
    Jacksonville, FL
    #12
    Me too...

    I've tried all the various settings mentioned here as well.

    I simply cannot get my iPhone to send email via GoDaddy's smtpout.secureserver.net

    I've tried...

    SSL on and off
    smtpout.secureserver.net
    smtpout.secureserver.net:80
    smtpout.secureserver.net:3535
    mail.secureserver.net

    POP works just fine..

    Any help is greatly appreciated. Thanks!
     
  13. macrumors newbie

    Joined:
    Sep 11, 2007
    #13
    Same Here

    I had the same problem. I tried all of the combinations above and still no luck. Finally I called goDaddy's tech support. They did an 'account reset' on their side, and I was up and running in less than 5 min.

    Give them a call, it worked for me.
     
  14. macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #14
    I use smtpout.secureserver.net:25

    It works for me. Your mileage may very.
     
  15. macrumors newbie

    Joined:
    Feb 8, 2008
    #15
    Try This For Godaddy Email On Iphone...

    ...I was having all the same problems as you did, I tried everything on the post, but finally I got it:

    - outgoing mail server is: smtpout.secureserver.net

    - I logged on to my GoDaddy.com account to manage the email; the smtp relaying was already turned on, but I noticed that my complete email was not listed as the outgoing smtp username. Instead, it was just the local-part of my email--without the domain part (e.g., @godaddy.com)

    - make sure to include you password

    This will work!!!
     
  16. macrumors newbie

    Joined:
    Jul 29, 2008
    #16
    solution with comcast

    I went through many of these options and found that, using my wifi network which is connected via comcast, the following worked:
    •*smtpout.secureserver.net
    •*no colon ":port", rather, enter the port number ONLY in the "port" field of the preference.
    •*no SSL;
    • password verification

    Note that at one point, I had a port number in both places (colon and field) and it caused my iPhone to quit out of mail and return to the home screen.
     
  17. macrumors newbie

    Joined:
    Aug 4, 2008
    Location:
    Southern California
    #17
    Iphone 3g mail works with cox communications or 3g

    It took me a while, but my iphone now works with either cox communications or over the AT&T 3g network (Cox blocks ports to preserve their monopoly try to force you to user their email). The instructions on the following link work pretty well:

    http://help.godaddy.com/topic/167/article/3423

    I had two problems that I had to overcome. First, I thought I had entered all the information I could and second, even though I knew that there should be more outgoing (SMTP) information to enter, it was not clear how/where to enter it. Here's how you do it:

    First, go to your Iphone's settings/mail-contacts-calendars/accounts screen. After you have entered your Pop Account Information and Your Incoming Mail Server Information, you still have to reenter the information for your outgoing server (this was not obvious the first time through):

    To do this, press the "SMTP" window in the "Outgoing Mail Server" location (if you already synced with outlook, the outgoing server may already be filled in as "smtpout.secureserver.net"). When you press it, a new screen opens up.

    On the next screen, click on the box under Primary Server (again it may already be filled in as: "smtpout.secureserver.net"). That will bring up yet another screen. This is the one you really want.

    On this screen, fill in the following information:
    1. your hostname ("smtpout.secureserver.net"),
    2. your Username (name@yourdomain.com),
    3. your password,
    4. turn "Use SSL" to "On",
    5. set Authentication to Password, and
    6. set Server Port to 465.
     
  18. macrumors newbie

    Joined:
    Jan 4, 2009
    #18
    GoDaddy SMTP and MobileMe

    After days of not being able to send mail, I think I have finally identified the culprit... MobileMe. I recently switched from POP to IMAP and non-SSL authentication to SSL authentication. I was not able to send mail for a week.

    To fix this problem; I went into Apple Mail (on all my MobileMe devices) and deleted a bunch of old and duplicated SMTP servers. I deleted my IMAP account on my iPhone. I then did a MobileMe sync to include all my mail accounts. (Be sure to catch all your computers before syncing. I deleted IMAP accounts and old SMTP servers on all my computers, except the authoritative big Mac daddy.) I plugged in my iPhone into the new fresh Mac and launched iTunes. I did a Sync to include all mail accounts. (Under the Info tab.) Be sure to check the box to "Replace Information on this iPhone" and check "Mail Accounts". Hit the Apply/Sync button. You should be in business.
     
  19. macrumors regular

    Joined:
    Jan 11, 2006
    Location:
    Hong Kong
    #19
    I'm having issues with getting my godaddy email set up on my iphone as well. I have it set up as POP on my MBP but want to get it set up as IMAP on my iphone (and subsequently change it to IMAP on my MBP as well).

    I followed godaddy's settings and set incoming server to: imap.secureserver.net and outgoing server to smptout.secureserver.net. I've also tried setting my incoming server to imap.xxxx.com since the setting for pop on Mail on my MBP is mail.xxxxx.com.

    I don't have issues with just sending. First it kept saying my username or password is wrong for imap.secureserver.net, which I know it's not true. I've triple checked on the typing. Then it says: Secure Connection Failed. The certificate for "name@xxxxx.com" may not be valid. It doesn't matter whether I turn SSL on or not.

    My mobileme and gmail accounts are working fine.

    Please help! Thanks!
     
  20. macrumors newbie

    Joined:
    Jan 25, 2009
    #20
    I have had the same problem and nothing seemed to work until I tried the following advice on http://www.snappermail.com/support/isp.cfm

    Their advice was to:

    POP3 Server: mail.godaddy.com
    Username: your entire GoDaddy Email address (i.e. username@godaddy.com or yourname@yourdomain.com)
    Password: your GoDaddy password
    Select "No SSL security".
    SMTP Server: smtpout.secureserver.net
    Username: your entire GoDaddy Email address (i.e. username@godaddy.com or yourname@yourdomain.com)
    Password: your GoDaddy password
    Select "No SSL security" (Premier/Enterprise editions). If you have trouble using the SMTP server, try setting the port number to 3535
    If you have difficulty setting up and/or using the GoDaddy SMTP server (i.e. you get a "501 Authentication failed" message), you may have to set up the relay configuration in your GoDaddy account.


    Once I had set the port number to 3535 it worked straight away. Good luck!
     
  21. macrumors 65816

    Joined:
    Aug 20, 2008
    #21
    I would strongly caution against using an e-mail server without SSL support.

    If you do, then anyone on the same WiFi network as you can monitor *and alter* any of your mail that passes over the network.
     
  22. macrumors newbie

    Joined:
    Jun 17, 2010
    #22
    Solution!

    Spent three hours with this yesterday. You have to get GoDaddy to reset your account. Then go to your webmail and empty your inbox. Delete GoDaddy account, reset iPhone and re-install GoDaddy account. Worked for me. Kudos to Hans at GoDaddy.
     
  23. macrumors newbie

    Joined:
    Oct 18, 2010
    #23
    Real Solution

    I have tried all these options and none of them works. As a matter of fact i have been trying trying to send emails from my iphone a few years now and i finally found the problem. You must configure your godaddy account settings. Log into your account and change the "SMTP relays per day" settings from 0 to 250. The default is set to 0 which means that you are allowed to send 0 emails/day. Once you change it to 250 then you are allowed to send up 250 emails/day. Try it
     

Share This Page