going CRAZY with new PreN Belkin Router

Discussion in 'Mac Accessories' started by vendettabass, Feb 21, 2007.

  1. vendettabass macrumors 6502a

    vendettabass

    Joined:
    Jul 8, 2006
    Location:
    Seoul, South Korea
    #1
    Absolutely fuming here, trying to get my PreN router to work with my macbook....

    my macbook is not picking up any wireless signal from the router, and also does not connect to the net through ethernet either!
    I really thought these things would be pretty plug and play, I've tried pretty much everything!

    Even the CD which claims to have mac drivers doesn't have any!

    Has anyone else had any problems with the belkin Pre N router?

    thanks, Gareth
     
  2. spaceballl macrumors 68030

    spaceballl

    Joined:
    Nov 2, 2003
    Location:
    San Francisco, CA
  3. Pili macrumors regular

    Joined:
    Nov 1, 2005
    Location:
    Orlando/Miami, FL
    #4
    It should still work no problem. i have 2 macs connected up to a pre-n in my house (powerbook and core duo macbook pro). There is a walk through guide online on belkin's website if you just search in support and select the router model. Was pretty helpful and had specific mac instructions as well.

    Is it just the macbook? Do you have any other pc's that you can test it on?

    sounds like an ip issue, do you have the router set to dhcp?
     
  4. netdog macrumors 603

    netdog

    Joined:
    Feb 6, 2006
    Location:
    London
    #5
    If it is a CD MB, it won't work with N, and the router must be set to accept G and work at 2.4GHz.
     
  5. vendettabass thread starter macrumors 6502a

    vendettabass

    Joined:
    Jul 8, 2006
    Location:
    Seoul, South Korea
    #6
    thanks for the replies!
    its a C2D with the N activated

    I'm back at uni now so I'll have a play with those settings mentioned at the weekend.. more questions to come I'm sure!
     
  6. iW00t macrumors 68040

    iW00t

    Joined:
    Nov 7, 2006
    Location:
    Defenders of Apple Guild
    #7
    Just curious, but how many dollars did you save buying the Belkin instead of the AEBS?
     
  7. Vtorch macrumors member

    Joined:
    Oct 31, 2006
    #8
    I would imagine it's a fairly good amount of savings.

    The Belkin Pre-N has been a discontinued model replaced by the Belkin (shiny black) Draft-N model.
     
  8. Vtorch macrumors member

    Joined:
    Oct 31, 2006
    #9
    I haven't had that problem. I have the Belkin Pre-N router. Just to make sure, it's the dark gray model with 3 antennas sticking out, right?

    Did you buy it new? My Belkin Pre-N just work, the day I bought it. I just plugged it in and it just worked. If you didn't buy it brand new, try restoring it to factory defaults, thus starting all over.

    Have you tried connecting your computer to the modem? Perhaps the modem is not connected to the net?
     

Share This Page