Google Chrome crashing iMac?

Discussion in 'Mac Applications and Mac App Store' started by Lava Lamp Freak, Feb 3, 2010.

  1. macrumors 65816

    Joined:
    Jun 1, 2006
    #1
    Twice in the last two days my iMac has turned off while I was in the middle of browsing, automatically rebooting itself. Both times the only console messages from the time that the crash occurred were from Chrome. Has anyone else experienced Google Chrome bringing a system down? The previous console messages were from 10:05. This is all there is before the crash happened, which was at 10:32:03. The iMac completed rebooting at 10:32:45. There was no error messages in the console or Finder upon rebooting.

    2/3/10 10:32:01 AM [0x0-0x2d72d7].com.google.Chrome[2930] [0203/103201:WARNING:/b/slave/chrome-official-mac/build/src/chrome/app/breakpad_mac.mm(62)] Breakpad disabled
    2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny file-read-data /Library/InputManagers
    2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny file-read-data /Library/InputManagers
    2/3/10 10:32:01 AM sandboxd[4622] Google Chrome He(4621) deny mach-lookup com.apple.windowserver.session
    2/3/10 10:32:03 AM [0x0-0x2d72d7].com.google.Chrome[2930] [0203/103203:WARNING:/b/slave/chrome-official-mac/build/src/chrome/app/breakpad_mac.mm(62)] Breakpad disabled
    2/3/10 10:32:03 AM sandboxd[4622] Google Chrome He(4623) deny file-read-data /Library/InputManagers
    2/3/10 10:32:03 AM sandboxd[4622] Google Chrome He(4623) deny file-read-data /Library/InputManagers
    2/3/10 10:32:03 AM [0x0-0x2d72d7].com.google.Chrome[2930] [2930:519:129394459522932:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/cocoa/browser_window_cocoa.mm(139)] Not implemented reached in virtual void BrowserWindowCocoa::ShelfVisibilityChanged()

    2/3/10 10:32:45 AM DirectoryService[15] Improper shutdown detected
     
  2. macrumors 65816

    Joined:
    Sep 19, 2009
    #2
    I don't use Chrome, but in a Unix environment an application crash should not bring the entire system down. Try using another browser for a while and see if it happens again.
     
  3. macrumors newbie

    Joined:
    Mar 22, 2010
    #3
    The very same thing happened to me yesterday 3 times in a row.
    Was browsing (idle) www.aftonbladet.se and bam - reboot.
    No messages or anything, just a superfast clean reset.

    Have not occurred since then...
    Could not find any useful in the console to help me figure out what happened
     
  4. macrumors newbie

    Joined:
    Nov 18, 2010
    #4
    Same Here

    That is the exact same thing that is happening with my iMac I just purchased 2 months ago. This is a pretty old thread (9 months old) but it looks like the same problem still exists. My iMac just completely shuts down instantly like somebody unplugged the power cord when using chrome and I do notice that improper shutdown console message right near the shutdown. It might be my extensions or something because I went for quite a while and this didn't happen. It only recently started and I can't figure out why. I've since switched back to Safari, but I really love chrome and the extensions you can have. It's too bad some of us can't use this browser without our macs totally crashing on us. :(
     
  5. macrumors 6502a

    macintoshtoffy

    Joined:
    Jul 1, 2009
    Location:
    New Zealand
    #5
    Have you run a memory test? did a clean install with all updates then run it? what are the hardware specifications because I wonder if you're running an iMac that has Flash which uses hardware acceleration whether a bug in the device driver is causing a kernel panic. Personally for me I haven't seen it happen on my iMac or my MacBook Pro - even still, run memtest86 and see what the results are.
     
  6. macrumors 6502a

    Joined:
    Jan 24, 2009
    #6
    I thought Chrome was amazing because of the slick interface. Then after awhile I realized it kinda sucked. GIF's cause the browser to lock up and freeze sometimes, Flash would cause it to freeze up, the most recent sites took forever to load on start up, it would automatically restart every freakin time I would restart the computer which was so damn annoying (and there was no way of changing it under preferences), and the typical "Do you want the browser to save your information" pop up was annoying with the way it popped up beneath the toolbar.

    Then I installed Safari 5 and realized how much better it is. Its faster, the scrolling is smoother, the top pages don't take forever to load like chrome, and the new article reader is AMAZING. Every time there is an article I click on that. It actually gets me to want to read it just because its so much more simplified.
     
  7. macrumors newbie

    Joined:
    Nov 18, 2010
    #7
    I just ran memtest (the default 3 times) and I have also run Apple Hardware Test from the boot disc and tech tool pro's memory test as well and all did not report any problems or errors. I am working on a mid-2010 iMac the i7 quad core, 16gb ram, every software is up to date.

    I did speak too soon though because the same power down/crash thing happen inside safari once. Not nearly happening as often as in Chrome but still happening. I wish I could figure out why. The weird part is in the console, the log is always mixed up about the time things happen, e.g. there is always one log entry that is after it should be when this crash occurs and I power back on; ex:

    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445963875:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890445983736:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446003635:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446023236:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446042588:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446061837:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446081206:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 2:57:59 PM [0x0-0x69069].com.google.Chrome[1010] [1010:34051:4890446100859:ERROR:/b/slave/chrome-official-mac/build/src/chrome/browser/sync/notifier/registration_manager.cc(126)] Registration failed with code: 12
    11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] com.apple.FolderActions.enabled: Already loaded
    11/18/10 3:19:35 PM kernel npvhash=4095
    11/18/10 3:15:40 PM [0x0-0x79079].com.apple.systemevents[1168] launchctl: CFURLWriteDataAndPropertiesToResource(/var/db/launchd.db/com.apple.launchd.peruser.501/overrides.plist) failed: -10
    11/18/10 3:19:35 PM kernel PAE enabled
    11/18/10 3:19:35 PM kernel 64 bit mode enabled
    11/18/10 3:19:35 PM kernel Darwin Kernel Version 10.5.0: Fri Nov 5 23:20:39 PDT 2010; root:xnu-1504.9.17~1/RELEASE_I386
    11/18/10 3:19:35 PM kernel vm_page_bootstrap: 4094157 free pages and 67379 wired pages
    11/18/10 3:19:35 PM kernel standard timeslicing quantum is 10000 us
    11/18/10 3:19:35 PM kernel mig_table_max_displ = 73
    11/18/10 3:19:35 PM kernel AppleACPICPU: ProcessorId=1 LocalApicId=0 Enabled



    Do you see how the kernel npvhash=4095 is in at 3:19:35 PM but is located in-between two 3:15:40 Pm's? That happens every time it crashes. I don't know if it suggests anything, but it is certainly weird from what I've seen other people posting on Apple Discussion Forums. Also there is a different log entry before every reboot or else I would be able to pin down what caused it (for example, it is not always the case that the failed launchctl is prior to the reboot)
     
  8. macrumors 6502

    JuanGuapo

    Joined:
    May 21, 2009
    Location:
    Los Angeles, CA
    #8
    Chrome 7 is the latest version, it supposedly fixed "hundreds" of bugs.

    http://goo.gl/m67Wy
     
  9. macrumors 6502a

    macintoshtoffy

    Joined:
    Jul 1, 2009
    Location:
    New Zealand
    #9
    According to that dump you're running in 64bit mode (boot using the 64bit kernel) - have you loaded it into 32bit mode? I've heard rumours that the 64bit kernel can cause problems so you might wish to try booting using the 32bit kernel.
     
  10. macrumors member

    Joined:
    Jan 10, 2009
    #10
    I am getting the same problemes here now.

    See these console message + error report (that was supposed to be send to Apple Inc): http://dl.dropbox.com/u/8355845/Feilmeldingene.rtf

    Brand new iMac... Maybe Chrome has something to do with this?

    Also have problems with it renedering some webpages properly. Love the all sync experience with Google, but I can´t continue with if this is being the error. :)

    Excellent if you can help out bros (and female friends). Already e-mailed my local dealer about this + the national forum for Mac.
     

Share This Page