Google Chrome & Google Chrome Renderer Activity Problem

Discussion in 'Mac Basics and Help' started by Rossagues, Nov 5, 2012.

  1. macrumors regular

    Rossagues

    Joined:
    Aug 12, 2012
    Location:
    Manchester, England
    #1
    I am using Google Chrome and I have one tab open. That is Facebook.

    I look into the Activity Monitor and i notice Google Chrome is using up 90% CPU and 306.9 MB of Real Memory.

    The Google Chrome Renderer is using 0.2% of the CPU but 1.5 GB of Real Memory.

    My machine has 8 GB ram. This is with only Facebook open. This alone is making my MacBook Pro 90 degree hot on iStat.

    Any advice? What can I do to prevent this

    Ross
     
  2. macrumors 65816

    Dolorian

    Joined:
    Apr 25, 2007
    #2
    Avoid Facebook :p

    Kidding, are you using the latest version of Chrome? What extensions do you have installed? Try quitting and restarting too.

    My MacBook Pro 13" also has 8GB of RAM and Chrome is currently using only 19% CPU with two windows and more than 10 tabs opened right now. I also have several extensions installed.
     
  3. thread starter macrumors regular

    Rossagues

    Joined:
    Aug 12, 2012
    Location:
    Manchester, England
    #3
    Chrome Version: 22.0.1229.94

    Extensions: AdBlock 2.5.47 & Adblock Plus 1.3 & Web of Trust 1.3.6


    Shall I uninstall and reinstall Chrome?
     
  4. macrumors 65816

    Dolorian

    Joined:
    Apr 25, 2007
    #4
    I am on the beta channel so I can't test to see if the same happens to me with that version. Try and use the beta version:

    https://www.google.com/landing/chrome/beta/

    I've been using it for a while and have experienced no problems.
     
  5. thread starter macrumors regular

    Rossagues

    Joined:
    Aug 12, 2012
    Location:
    Manchester, England
    #5
    I'm all for BETA's but whats so different about it?
     
  6. macrumors regular

    Joined:
    Sep 24, 2011
    #6
    Try removing one of your adblocking extensions. You really only need one running at a time.
     
  7. macrumors newbie

    Joined:
    Dec 1, 2012
    #7
    hi,

    I had the same problem with the Google Renderer hitting 90% CPU, and it was affecting whenever i opened Facebook and even the google.com page!!

    at first i thought it was the Adobe Flash and Shockwave plugin, so i re-installed, removed, disabled, you name it i tried it, but no luck.

    I went through my plug-ins again and found a Facebook plugin called "Facebook Video Calling Plugin" , i disabled that and voila! all is working like a charm now.

    I hope this can benefit someone out there.
     
  8. macrumors newbie

    Joined:
    Sep 10, 2008
    #8
    this solved my problem, thanks!

    odd thing is that it only happens when using my discrete graphics card which had me thinking maybe it was going bad
     
  9. macrumors newbie

    Joined:
    Apr 7, 2013
    #9
    Thank you so much!

    OMG khaledhawari! Thank you so much!

    I have been trying to solve this problem for months, I often leave my MBP on unattended and will come back to find my facebook tab having ballooned up to 1gb of memory and 90% cpu, my fan going nuts. I'm on the latest version of OSX, Chrome, everything. What confused me even more is that I have a similar macbook at work and never have this issue so I couldn't figure out what the difference is, and it's an incredibly difficult problem to google for, but you solved it! Again, thank you so much, you have no idea how much this has been bothering me!
     
  10. macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #10
    The same happens to me but I do not have this facebook plugin installed on my Chrome.

    I'm tired of waking up in the morning and my MacBook is with the fan maxed out just because of this stupid "bug".

    Anyone knows what else could be?
     
  11. macrumors newbie

    Shlomit

    Joined:
    Feb 1, 2009
    Location:
    Born in Jerusalem, lives in Tel-Aviv,
    #11
    Same here, no facebook plug installed :(

    got the same issue,
    got not Facebook plug-in installed.
    any other solutions?
    thnaks:)
     
  12. macrumors newbie

    Joined:
    May 26, 2013
    #12
    feedly extension

    I had this same issue. I do not have the facebook video extension... rather, I had to disable the feedly.com extension that was taking a lot of processor time. That worked.
     
  13. macrumors 6502

    Joined:
    Jan 19, 2010
    #13
    Woah, Chrome is quite the CPU hog... I'm running Safari with two windows, 15 tabs open, plus Preview and Finder in the background, and only using 3% CPU on my iMac. It might just be because the iMac has a more powerful CPU, but that seems very excessive.
     
  14. macrumors newbie

    Joined:
    Jul 7, 2013
    #14
    I force quit Google Chrome Renderer, and a popup message says that Gmail Offline has encountered a problem. This immediately stops the high CPU usage, and the temperature of the laptop starts dropping within ten seconds.

    Does anyone know a more permanent fix? I can't see a Gmail Offline app that I can disable.
     
  15. macrumors newbie

    Joined:
    Jul 9, 2013
    #15
    For me it was the Google offline as well. I stopped the Google Chrome Worker process that was taking 100% CPU and immediately got a message that Gmail Offline had experienced a problem.

    Now my mac is nice and quiet again, so quiet!

    @macca7174 To uninstall Gmail offline, just go to your apps page (scroll your startup screen to the right), right-click on Gmail Offline and choose Remove from Chrome. Maybe you also want to delete the cookies associated with that, it can take quite some disk space.
    1. Type chrome://settings/cookies into your address bar and press enter
    2. Search for mail.google.com
    3. Hover over the search results and click the X that appears
     
  16. macrumors newbie

    Joined:
    Jul 17, 2013
    #16
    I managed to bring down the CPU usage of the "Google Chrome Renderer" process using this method:

    1. At Chrome, click "View Background Pages".
    2. Sort by the CPU tab.
    3. Note the tab that appears at the top.
    4. Switch to that tab.

    I found that perhaps after the tab is shown in the foreground, it completes loading/rendering and idles down.
     

Share This Page