Google chrome on the iPad

Discussion in 'iPad Apps' started by GeorgieAcevedo, Jun 29, 2012.

  1. macrumors 6502a

    GeorgieAcevedo

    Joined:
    Apr 12, 2012
    Location:
    New York City
    #1
    I tried the app. I like it. But I notice a bit of lag when scrolling on every page.

    Maybe that's just happening to me or maybe that's because I'm running iOS 6. Has anyone experienced that happening?

    I really want to use it but that's holding me back. I would like some feedback on other users experiences with google chrome for iOS on the iPad.
     
  2. macrumors member

    Joined:
    Jun 17, 2012
    #2
    Having an issue with the bookmark sync that's about it though with complaints
     
  3. macrumors member

    Joined:
    Mar 24, 2011
    #3
    I tried it on a few web sites and so far find it to be faster than Safari.
     
  4. macrumors 6502

    Joined:
    Sep 9, 2007
    Location:
    Little Rock, AR
    #4
    I like it, but it doesnt seem fair that developers cant use the same Nitro engine that Safari makes use of. Apple is pulling the same stund Microsoft did in the 90's when it was Internet Explorer vs. Netscape.
     
  5. macrumors 6502

    Joined:
    Mar 30, 2011
    #5
    The look is refreshing but definitely seems to be slower than Safari.
     
  6. macrumors 68040

    Badrottie

    Joined:
    May 8, 2011
    Location:
    Los Angeles
    #6
    Chrome looks awful on some websites…very lagging!
     
  7. macrumors 6502a

    Joined:
    Dec 28, 2004
  8. macrumors 604

    onthecouchagain

    Joined:
    Mar 29, 2011
    #8
    It's cause it's not the real Chrome. It's more or less a skin of Chrome. Such a shame it can't be fully realized because of Apple's strict and stubborn rules. Chrome browser is actually fantastic.
     
  9. macrumors 6502a

    Joined:
    Jun 9, 2009
    Location:
    UK
    #9
    I may have to make Chrome my default browser as it doesn't give me the issue Safari does on my ipad, which is not loading all images in Google search.:mad: I've tried resetting Safari, clearing cache...nothing works.
     
  10. macrumors member

    wizee

    Joined:
    Mar 16, 2011
    Location:
    Pennsylvania
    #10
    Tried it this weekend, no problems, seems to run faster
     

Share This Page