Google Maps (non-iOS) for Taipei...in English?

Discussion in 'Apple, Inc and Tech Industry' started by PaperQueen, Feb 11, 2013.

  1. macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #1
    When searching Google Maps (browser version, not iOS) for locations in Taipei, the street, alley, and lane numes are in Chinese. When I look at the Mastercard ATM search maps, however, their Google maps for the same areas include English translations.

    From the MasterCard ATM search pages:
    http://www.mastercard.us/cardholder-...m-locator.html

    [​IMG]

    But...

    ...here's the same area, viewed on the Google Maps site:

    [​IMG]

    I can't for the life of me figure out how to access the bi-lingual version of Google maps. There used to be an option in the upper right hand drop-down menu, but no more.

    • I'm sitting in Minneapolis, so the default local language should be English (my Google account is set up for Engish too).

    • Have tried both with and without logging into my Google account...no difference.

    In the end, I'd like to be logged into my account, set pins on a My Places map, send the link to my iPhone 5, then save a shortcut to my home screen (Safari > Add to Home Screen) for viewing while in Taipei.

    (Obviously hoping it doesn't convert back to Chinese when viewed in Taipei.)

    I'm stumped. Anyone have the magic potion for this? :confused:
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    I still have the option in Safari 5.0.5 on Mac OS X 10.6 Snow Leopard.

    [​IMG]
     
  3. PaperQueen, Feb 11, 2013
    Last edited: Feb 11, 2013

    thread starter macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #3
    Hmmm...interesting that you have English in the drop down using Safari---it's not there when I try the same (Safari 6.0.2 on MBA running 10.6.8):

    [​IMG]

    Nonetheless, the map in your example still shows street, alley, and lane names in Chinese, with the exception of only major thoroughfares. The Google map MasterCard links to converts all of them into English, which is what I'm hoping for.

    Thanks for chiming in, though---you never know who might have the magic bean in their pocket. ;)
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    [​IMG]
     
  5. thread starter macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #5
    From the endless trial an error I've done, it appears that being logged into my Google account forces Chinese to appear (and, oddly, removes the English option from the drop down menu). Doesn't matter which computer, which browser...the moment I log into my Google account, it forces Chinese.

    (Already checked and yes, Account Settings > Languages > Primary is set to English-American. For extra support, I selected English-UK as my second language. Still no joy.)

    Anyone have a clue why this is happening?

    P.S. to simsaladimbamba: I noticed your drop down omits Weather as an option. Any idea why? That might be a hint as to what causes the menu to differ from one user to the next.
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    I am not logged into any Google account, but I am logged into my YouTube account, which does not seem to matter that much as it seems. My primary OS language is British English and then there is nothing else I can think except browser and OS versions.
     
  7. Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    Whakatane, New Zealand
    #7
    I also have the "English" option when using British Firefox 17.0.2 on Windows.
     
  8. thread starter macrumors 6502

    PaperQueen

    Joined:
    Aug 16, 2007
    Location:
    Just this side of insanity (Minneapolis)
    #8
    My hope is that someone will know what hidden setting needs to be changed on my Google account that's forcing it into Chinese on Taipei maps the moment I log in. When logging in using someone else's Google account, English appears---when logging in with mine, it's gone.

    As mentioned above, my Account settings show English/American as the default language, so that can't be the solution. :::sigh:::
     

Share This Page