Google Maps not pointing to direction of travel

Discussion in 'iOS Apps' started by MN7119, Jan 10, 2013.

  1. macrumors regular

    Joined:
    Mar 7, 2011
    #1
    When using the Google Maps app on my iPhone 5 I noticed that it does not show the orientation based on my path of travel but shows the map pointing to North. Is there a way to change that?
     
  2. macrumors 6502a

    moldy lunchbox

    Joined:
    Sep 9, 2010
    Location:
    Raleigh, NC
    #2
    Goto Settings and turn on Location Settings for Google Maps, and the compass will spin.
     
  3. thread starter macrumors regular

    Joined:
    Mar 7, 2011
    #3
    I have it on for Google Maps under Location Services and still do not get the map to show in the direction I am traveling.
     
  4. macrumors regular

    Joined:
    Nov 3, 2004
    #4
    You mean other than by pressing the button in the bottom left of the screen?
     
  5. thread starter macrumors regular

    Joined:
    Mar 7, 2011
    #5
    When driving I usualy have my iPhone on with Google Maps open even if I am not using it to show directions to go from point A to point B. While driving the app shows a blue dot (my iPhone location) and as the car moves the dot moves but NOT in the direction the car is moving. If am heading south and making a right turn to head west, with the orientation pointing North, makes it look like am turning left. BTW, pressing the small arrow on the botton left of the screen does not change the orientation of the map.
     
  6. macrumors 6502a

    Stuntman06

    Joined:
    Sep 19, 2011
    Location:
    Metro Vancouver, B.C, Canada
    #6
    Not sure about the iOS version, but the Android version has a Navigation icon for Google Maps. When you launch it from the Navigation icon (instead of the Google Maps icon) and go to the map, it will show the navigation display as if you are driving to a destination, only it has no pre-planned route. You may want to check if the iOS version of Maps has a navigation display within the app. Try navitating without a destination if that is possible.
     
  7. MacDevil7334, Jan 10, 2013
    Last edited: Jan 10, 2013

    macrumors 6502

    MacDevil7334

    Joined:
    Oct 15, 2011
    Location:
    Austin TX
    #7
    You need to press the "locate me" button in the bottom left twice in a row. The first press locates you on the map. The second time activates the compass and causes the map to orient itself to the direction your phone is facing. Should work fine while driving.

    edit: Another option would be to enter your destination and then use the app's navigation mode with the voice guidance muted. You would still see the blue line for the app's planned route, but the map would always follow the direction of your car.
     
  8. macrumors 65816

    Joined:
    Oct 23, 2008
    #8
    You have a talent for using so many words for describing a problem and still not making it clear what the problem actually is.
     
  9. macrumors 68040

    Dwalls90

    Joined:
    Feb 5, 2009
    #9
    Click the compass in the upper right hand corner of the map.

    That will toggle it from always showing due north, or showing the direction of your vehicle.

    If that doesn't work, ensure location services are permitted for the app in settings.
     
  10. macrumors 6502

    Joined:
    Mar 27, 2009
    #10
    Same thing happened to me the other day even when I clicked the arrow compass button. I restarted the app and it worked fine.
     
  11. macrumors 6502

    Joined:
    Feb 13, 2011
    #11
    Overnight, Google Maps is no longer pointing in the right direction on rotation. It always points north.

    I have:
    -reinstalled the app
    -Calibrated Compass app - figure of 8 etc.
    -Pressed the Compass icon on and off in Google Maps.
    -Orientation is fine in Apple Maps

    Any suggestions?

    ----------

    Btw: iPhone 5

    ----------

    And I've hard reset the phone...
     
  12. macrumors member

    Joined:
    Jun 28, 2006
    Location:
    california
    #12
    Mine does this too randomly!! Maybe it's a software bug? I just hold it upside down or sideways when it happens ... I mostly use google maps for traffic updates.
     
  13. macrumors regular

    Joined:
    Nov 8, 2011
    #13
    This is very frustrating. I too have been experiencing this for the past week.
    Not sure why'd has encasing this, but it has greatly effected my daily travel (using google maps every other day).
    Extremely frustrating.
     
  14. macrumors 6502

    Joined:
    Feb 13, 2011
    #14
    Just out of interested... are we all jailbroken?
     
  15. macrumors 6502

    Joined:
    Feb 13, 2011
  16. macrumors 68000

    Joined:
    Feb 9, 2014
    #16
    Compassgate.
     
  17. macrumors newbie

    Joined:
    Apr 15, 2008
    #17
    Compass Icon

    Try tapping on the compass icon while in the navigation mode. It should toggle between pointing north and to the direction your device is heading.
     
  18. macrumors 6502

    Joined:
    Feb 13, 2011
    #18
    Have a read of post #11
     
  19. macrumors 6502a

    Joined:
    Dec 27, 2010
    #19

    Google-gate. Google makes the Google Maps app.
     
  20. macrumors 6502a

    Joined:
    Oct 27, 2007
    #20
    Use waze in the meantime. Google maps is strange, sometimes it's perfect, sometimes its plain dumb. An update should be imminent
     
  21. macrumors P6

    Joined:
    Oct 17, 2011
    #21
    Are system services for various location items enabled? Like compass calibration and the like?
     
  22. macrumors 6502a

    Joined:
    Dec 27, 2010
    #22
    With iOS 8, I just open in default Apple maps, and enter my destination route and select "App" we can now choose any map app and open up that app and your destination info loads right in.
     
  23. macrumors newbie

    Joined:
    Nov 1, 2014
    #23
    i had this problem today on my iphone 6 running ios 8. it is just a simple case of touching the compass icon on the right hand edge of the screen (while in sat nav mode). it toggles the view from map facing north to arrow facing north (direction of travel).
     
  24. macrumors 6502

    Joined:
    Feb 13, 2011
  25. macrumors newbie

    Joined:
    Nov 3, 2014
    #25
    I was experiencing the same issue, and this solved it for me. Location access must be enabled for Compass in Location Services.
     

Share This Page