Griffin iMic sound issue

Discussion in 'Macintosh Computers' started by Hibbity, Apr 18, 2005.

  1. Hibbity macrumors member

    Joined:
    Feb 28, 2005
    #1
    I just got a Griffin iMic for my mac mini. I hooked it up and went to system preferences > Sound > Output and changed the device to the iMic. I hooked my stereo up to the iMic, but only iTunes will play sound through the iMic to my stereo. Sound from websites, such as homestarrunner.com, and anything played on VLC all still play through the little built-in speaker.

    Is there any way to change this?
     
  2. Hibbity thread starter macrumors member

    Joined:
    Feb 28, 2005
  3. sorryiwasdreami macrumors 6502a

    sorryiwasdreami

    Joined:
    Apr 24, 2004
    Location:
    way out in the sticks
    #3
    There is a tiny switch on the bottom of the iMic; have you tried toggling back and forth?
     
  4. dvdh macrumors 6502

    dvdh

    Joined:
    Apr 6, 2004
    #4
    Similar problems . . . but worse

    With my iMic (on an iBook) I have had no success with getting sound out at all. The sound in works fine with all the apps, but no output, no matter what settings, what USB port, or connector on the iMic. Fortunately, I only really bought it too use as an input device, but would like the out to work as well.
     
  5. sorryiwasdreami macrumors 6502a

    sorryiwasdreami

    Joined:
    Apr 24, 2004
    Location:
    way out in the sticks
    #5
    Guys try this:

    Go to System Preferences. Click Sound. Near the top of the window you will see three choices: "Sound effects, output, and input." Choose Output. You will see two or more choices to pick from: "Line Out and iMic USB audio system." Choose the iMic.

    Make sure you flip the physical switch on the bottom of the iMic to the speaker icon. Test to see if you are getting sound.

    [​IMG]
     
  6. dvdh macrumors 6502

    dvdh

    Joined:
    Apr 6, 2004
    #6
    Okay, I'm confused. I plug in everything correctly (check the directions on the very short manually included), set up the setting as you showed. . . and nothing . . . not a sound. Then on a whim, I checked the mute box. Obviously no sound. Unchecked it: and voila, it works. No idea why I would have to mute and unmute the device to make it active, but thanks, it works now.

    . . . But in answer to the original question, it only works in iTunes (and Quicktime) for me as well.
     
  7. Hibbity thread starter macrumors member

    Joined:
    Feb 28, 2005
    #7
    Yeah I've got it set up like Sorryiwasdreami outlined, but still, only iTunes and Quicktime output sound through it. Who knows, maybe Tiger will fix this :)
     
  8. redeye be macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #8
    Check these settings:
    [​IMG]
    Maybe changing your 'play alerts and sound effects through' will work for you.

    Good luck
     
  9. Simon Liquid macrumors regular

    Joined:
    Jul 4, 2001
    Location:
    Iowa
    #9
    Ok, forgive me if I misunderstand and everything is already solved, this is my own experience with VLC and an iMic.

    In VLC, there's an audio menu and a submenu where you can select the iMic. You need to be playing a movie to access the menu, which is sort of flaky.

    There's a bigger bug, or at least there was when I was using an iMic to plug my headphones in like a year ago. Every time I started a movie in VLC it set the audio quality to 8 bits which sounds pretty lousy. The only solution I could find was the AUdio MIDI Setup app located in the utility folder. You can set the audio output quality from there but you have to do it again every time you start a movie. It was a drag, but they may well have fixed the bug in the intervening time.
     
  10. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #10
    I don't think this matters for audio output. I'm pretty sure the switch just selects the signal level (mic/line) for audio input. I just checked Griffin's web site:

    The switch between the input and output ports only controls the input, and is used to turn the iMic's preamp on and off.​

    FWIW, I used to use my iMic with my iBook and after setting the Audio Preferences to the iMic in the output pane I got all my output through the iMic.

    Good luck!
     
  11. Hibbity thread starter macrumors member

    Joined:
    Feb 28, 2005
    #11
    Thanks Simon Liquid, I fixed the problem with VLC. Now the only problem is getting internet sounds to go through the iMic; everything else does. I tried using firefox, but still, same problem.

    I have to say, the touted "tight integration" of OSX does not appear to be all its made out to be; iTunes, but not Safari, changes its input when changed in system prefs. Honestly, thats pretty disappointing.
     
  12. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #12
    As iMic user, I know this issue. You need to change the output device in
    Applications/Utilities/Audio-MIDI-Setup
    Launch it. In it you will see "Standard-Output" and "System-Output". If you set BOTH on the iMic, all sounds, and I really mean it, ALL sound will be played over the iMic.

    I am having some other trouble with iMic. Not rarely, the input is pure crap, since only very loud stuff over the attached mic will be shown at the meters. Everything more quiet is filtered out. I suppose in the meantime its some issue with the Apple USB audio driver, but I have no idea how to fix that.
    Edit: No, its not the line/mic-level switch on the iMic... ;)

    I cant use the mic at anything, the input is all screwed. The output works fine though. Really weird.

    Ideas?
     
  13. redeye be macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #13
    It's a long shot, but have you tried upping the input volume?
    System preference - Sound - Input - the first volume thingy. Play with it while talkin in the mic.
    I have my headset connected, if i put the input volume to the mac, i can see myself breath.

    Good luck
     
  14. diddy macrumors 6502

    Joined:
    May 13, 2003
    Location:
    Las Vegas, NV
    #14
    You can also boost the input volume in Audio MIDI Setup in Utilities.
    Select Properties For: iMic, and crank up the slider at the bottom of the window under Audio Input.
     
  15. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #15
    Sorry guys, this problem apparently runs deeper. Even at max gain, the iMic only transmits very loud input (like yelling into the mic). It must be either some hardware or some software issue, but nothing in the settings.
    Thanks for trying to help though.
    I think about getting myself a M-Audio Revolution 5.1 as a replacement...
     

Share This Page