Group MMS, iPhone 5, and T-Mobile

Discussion in 'iPhone' started by adamfishercox, Nov 25, 2012.

  1. adamfishercox
    Expand Collapse
    macrumors 6502

    Joined:
    Aug 15, 2007
    #1
    I'm using the iPhone 5 on T-Mobile, and Group MMS doesn't work. It works fine if everyone uses iMessages, which makes sense, but if I add in anyone without an iPhone, my group message just sends as an individual text from me.

    For example: I send a group text to Tim, Matt, and Bob. Each of them gets a message from Adam, but the other members aren't included in it. If they reply, I get the reply as a message from Bob, but Tim and Matt don't get it at all.

    I flat out do not receive group messages that others have started. For example, if Bob creates a group text with Matt, Tim and me, Matt and Tim will get a group text as intended and can reply to each other, but I get nothing. Not an individual text, not a group text: nothing.

    Does anyone know a) why this would be a problem and b) if there's any non-jailbreak way to fix this or even just an app to work around it?
     
  2. Mr Hill
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 28, 2012
    Location:
    Charlotte, NC
    #2
    It should work fine without a jailbreak. When you go to the messages settings just make sure group messaging is on. Mine is working on my 4S with no issues.
     
  3. adamfishercox
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Aug 15, 2007
    #3
    that's part of the problem, I don't even have that toggle. You have it on TMobile without doing anything besides popping in the SIM?
     
  4. Daveoc64
    Expand Collapse
    macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #4
    To see the toggle (and use the functionality), it has to be enabled by your carrier.

    As your carrier (T-Mobile USA) isn't a supported carrier, they have no way to actually do that.
     
  5. Mr Hill
    Expand Collapse
    macrumors 6502

    Joined:
    Apr 28, 2012
    Location:
    Charlotte, NC
    #5
    Yeah when I put my sim inside it just worked like an iPhone does on a supported carrier. Does your FaceTime and iMessage work? Maybe try removing and re inserting the sim to see if the option pops up.
     
  6. nostaws
    Expand Collapse
    macrumors 6502

    nostaws

    Joined:
    Jan 14, 2006
    #6
    So, I am on t-mobile, and I do have those options, I have turned them on and I still can't:

    1. send group messages
    2. consistently receive group messages. I occasionally receive messages from people replying to the group.

    A question for those not receiving messages: do you have a data plan or are you phone only and data only when you have wifi?
     
  7. adamfishercox
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Aug 15, 2007
    #7
    I have a data plan. Here's hoping things get better now that T-Mobile and Apple are official partners
     
  8. Applejuiced
    Expand Collapse
    macrumors Nehalem

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    MMS and group messages do need carrier data.
    If you dont have a data plan then that's why those features are not working.
     
  9. Minhimalism
    Expand Collapse
    macrumors 6502a

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #9
    I'm on T-Mobile and I can send and receive group messages just fine.. as can my other friends, and we never had to enable anything.
     
  10. flexbrah
    Expand Collapse
    macrumors newbie

    Joined:
    Jul 10, 2011
    Location:
    Tampa, FL
    #10
    What are your APN settings?
     
  11. Minhimalism
    Expand Collapse
    macrumors 6502a

    Minhimalism

    Joined:
    Jan 6, 2012
    Location:
    Texas
    #11
    The same ones they tell you to do for MMS. When I set this phone up it was already set.. (edit: I take that back I had a backup from my pre-swap iPhone 5 that I had edited the plist on.. but I basically just set things for MMS as anyone else would, not group message.) And MMS and what not all just work. It was glitchy for a day, but now my group message works just fine!

    http://support.t-mobile.com/thread/17918?tstart=0
     

    Attached Files:

Share This Page