Guide: Enable native NTFS Read/Write in Snow Leopard

Discussion in 'OS X' started by Chrysaor, Sep 12, 2009.

  1. macrumors 6502

    Joined:
    May 16, 2006
    #1
    This is experimental, and known to be unstable, use at your own risk.

    I am sure many of you heard that Snow Leopard was supposed to have native read/write for NTFS partitions. Apple supported NTFS R/W in older SL builds but I guess decided to not to go with it for some reason, however support is still present.
    For this, you need to modify your /etc/fstab file to mount NTFS partitions for read and write.

    First, uninstall NTFS-3G/Paragon if installed.
    Open Terminal.app (/Applications/Utilities/Terminal)
    Type "diskutil info /Volumes/volume_name" and copy the Volume UUID (bunch of numbers).
    Backup /etc/fstab if you have it, shouldn't be there in a default install.
    Type "sudo nano /etc/fstab".
    Type in "UUID=paste_the_uuid_here none ntfs rw" or "LABEL=volume_name none ntfs rw" (if you don't have UUID for the disk).
    Repeat for other NTFS partitions.
    Save the file (ctrl-x then y) and restart your system.

    After reboot, NTFS partitions should natively have read and write support. This works in both 32 and 64-bit kernels. Support is quite good and fast, it even recognizes file attributes such as hidden files.


    Alternative Method by iBlacky:
    Rename the original /sbin/mount_ntfs tool:

    sudo mv /sbin/mount_ntfs /sbin/mount_ntfs.orig

    Create a script like this:

    #!/bin/sh
    /sbin/mount_ntfs.orig -o rw "$@“

    save the script to /sbin/mount_ntfs

    sudo chown root:wheel /sbin/mount_ntfs
    sudo chmod 755 /sbin/mount_ntfs

    Enjoy R/W access to NTFS volumes...

    In case you don't like it

    sudo mv /sbin/mount_ntfs.orig /sbin/mount_ntfs

    and everything is back to R/O.
     
  2. macrumors 68020

    Joined:
    Aug 28, 2009
    #2
    Am about to install Boot Camp in SL. Thank you for the tip :)
     
  3. macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #3
    ? I'm not seeing this number sequence.
     
  4. thread starter macrumors 6502

    Joined:
    May 16, 2006
    #4
    Should be like this:

    [​IMG]

    Alternatively, you can get it from Disk Utility.app,
    [​IMG]
     
  5. macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #5
    Just a note. You need to create the fstab file for my instructions to work. Use that sudo nano command Chrysaor wrote down in the first post. Try typing LABEL= this time.

    Thanks for your help Chrysaor I would have never known Snow Leopard could do this was it not for your thread. I (finally) got this working albeit a different and probably more dangerous way...

    1. opened terminal and typed
    Code:
    open /private/
    2. gave myself read/write permissions the manual way for private, etc, and the fstab file (see attachment) by highlighting each folder and file and then pressing command I

    3. typed
    Code:
    LABEL=Erebus none ntfs rw
    were Erebus is the name of my bootcamp partition and then saved the fstab file.

    4. rebooted.
     

    Attached Files:

  6. macrumors newbie

    Joined:
    Sep 12, 2009
    #6
    This works great, but I can't seem to find the UUID for my flash drive? Maybe I'm looking for something that doesn't exist?

    Any help would be appreciated. This tip works great for the bootcamp partition but without full access to my flash drives that are NTFS it leaves more to be desired.

    Thanks!

    -David
     
  7. macrumors newbie

    Joined:
    Sep 12, 2009
    #7
    Just plugged in my external HD that is NTFS and it works. It has a UUID so I guess maybe flash drives do not have a UUID?

    I wonder if KingYaba's method would work for flash drives? I may try this if I can not find the information about flash media that I need....


    EDIT: I tried using "LABEL=" and the drive name in my case it was a kingston flash drive I have not renamed yet. so I did "LABEL=KINGSTON none ntfs rw" and saved the file. Rebooted and it works now. So I guess if there is not a UUID just use LABEL and the drive name and that should work. Tested and I was able to write a file to the drive. Thanks for the inspiration!
     
  8. macrumors 68020

    Shake 'n' Bake

    Joined:
    Mar 2, 2009
    Location:
    Albany
    #8
    How do I save the file?
     
  9. macrumors newbie

    Joined:
    Sep 12, 2009
    #9

    On the bottom of the terminal window you can see the command list...

    To quit nano you type ctrl + x

    It will then ask if you want to save. Type in "y" (without quotes) and hit enter.

    Then it will confirm the filename to save so you can just hit enter one more time and then it's saved.
     
  10. macrumors 68020

    Shake 'n' Bake

    Joined:
    Mar 2, 2009
    Location:
    Albany
    #10
    Thanks. Now I just need to reboot, which, for me, is rarely.
     
  11. macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #11
    Nice find, I think this should be made into a sticky or incorporated into the SL tips/tricks sticky.
     
  12. thread starter macrumors 6502

    Joined:
    May 16, 2006
    #12
    Updated the first post with LABEL, didn't realize some disks may not have one.
     
  13. macrumors 68020

    Shake 'n' Bake

    Joined:
    Mar 2, 2009
    Location:
    Albany
    #13
    Works perfectly. Thanks for the tip!
     
  14. macrumors 6502

    occamsrazor

    Joined:
    Feb 25, 2007
    #14
    Great tip... I wonder if someone with the knowhow might turn it into a preference pane etc... makes you wonder why Apple didn't do something with it.
     
  15. macrumors 6502a

    Joined:
    Jun 5, 2007
    #15
    didnt work for me with the UUID.

    i will try the LABEL method this time

    EDIT: ive tried multiple times with both methods, but neither works...

    ill keep trying, though... this will let me share itunes btwn boot camp and mac os x!!

    EDIT2: this is my line in fstab

    UUID=4161BE66-95D9-4776-AD13-01A5F5D37C29 none ntfs rw

    anything wrong?

    EDIT3: theres another file named fstab.hd. is this the one that should be edited?
     
  16. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #16
    Interesting, I wonder if this was disabled by default because of licensing issues?
     
  17. macrumors newbie

    Joined:
    Sep 12, 2009
    #17

    Not sure what you mean by another file named fstab.hd?

    If you go into /etc/fstab from terminal it should find and edit the correct file.
     
  18. macrumors 6502a

    Joined:
    Jun 5, 2007
    #18
    oddly, after about 3 or 4 restarts (with my fstab file staying the same), it said i could write now
     
  19. macrumors newbie

    Joined:
    Sep 12, 2009
    #19
    At least it works!

    P.S. Working on a script to do this automatically... all you will need to do is enter the drive label... hope this will help some people out...


    -David
     
  20. macrumors 68020

    Tex-Twil

    Joined:
    May 28, 2008
    Location:
    Europe
    #20
    wow so is this a real native RW NTFS support ??
     
  21. macrumors member

    Joined:
    May 14, 2009
    Location:
    Ankara, Turkey
    #21
    Hooray! :p
     
  22. macrumors member

    Joined:
    May 14, 2009
    Location:
    Ankara, Turkey
    #22
    I hope that it won't violate the license :rolleyes:
     
  23. macrumors newbie

    Joined:
    Aug 20, 2009
    #23
    Thanks for the heads up. It works for me. however, I encountered 2 problems.

    1. When I tried to delete a certain folder, it became 0 byte but was still shown in the trash with an error msg (file corrupted or something). It happened before (mainly with folders). But previously, I could go to disk utility - first aid - repair disk to correct this. However, now the 'repaire disc' button is disabled for these NTFS disks.

    2. When I tried to save a pdf file in its original place (i.e., replacing the original one) using Acrobat, I suddenly got an error msg, then I found the folder the file was in was empty! (I had over 2GB of files in that folder!)

    -------------------
    Update: I was able to solve these problems. I used the chkdsk command line utility (in particular, run cmd, then type 'chkdsk K: /X' where K is the drive letter, /X means to unmount it first) to repair the disk under windows. The contents in the folder were intact.

    Also, I was able to find and delete the /etc/fstab file eventually, by going to finder-go to folder- '/etc'. After I reinstalled paragon, the repair disk button is clickable again.
     
  24. macrumors newbie

    chavanak

    Joined:
    Aug 26, 2009
    Location:
    On Earth?
    #24
    I am getting this in console:
    9/14/09 11:43:13 PM com.apple.autofsd[49] automount: Mount for LABEL=Softwares has no path for the directory to mount

    I am trying to mount an external drive which has two partitions. My fstab entry is:
    LABEL=Software none ntfs rw.
    Ca someone tell me what I am doing wrong/
     
  25. macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #25
    You're missing an s?
     

Share This Page