Half Life 2 on Boot Camp Drivers Issue

Discussion in 'Mac and PC Games' started by Soulstorm, May 1, 2007.

  1. macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #1
    I have purchased Half Life 2 with Episode 1 expansion.

    Half life 2 starts fine, but upon the Episode 1 launch, I get a warning saying that my videocard driver is outdated.

    I have an X1600 that comes with the 17" intel iMac model. So, I go to ATI and I download the latest catalyst drivers for X1600 series, only that they don't work, because the installer says that " Setup did not find a driver compatible with your current hardware or operating system".

    What can I do? Does Boot Camp install its own drivers and they can't be changed?
     
  2. macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #2
    Sounds like you just downloaded the wrong ATI drivers for your card and Windows version. The catalyst drivers work fine under boot camp.
     
  3. thread starter macrumors 68000

    Soulstorm

    Joined:
    Feb 1, 2005
    #3
    But I downloaded the drivers for the x1600 series for my Mac 17". Did I download the wrong drivers? Can you tell me what drivers should I download?
     
  4. macrumors 68020

    Joined:
    Jul 3, 2003
    #4
    I'm pretty sure I used the default Apple drivers, and I think I had to Google ATI drivers for the X1600 in Boot Camp.

    Well, I know that I at least played Episode 1 on my MacBook Pro. :D
     
  5. macrumors newbie

    Joined:
    Jul 27, 2005
    #5
    I get the same message on my MBP, and have yet to have any issues with gameplay in Episode 1. Usually that isn't something you should ignore, but if there aren't any new drivers, well then there isn't anything you can do but just play.
     
  6. macrumors 68000

    Haoshiro

    Joined:
    Feb 9, 2006
    Location:
    USA, KS
    #6
    I had exactly the same warning and just ignored it and continued anyway... worked just fine! :)
     
  7. macrumors member

    Joined:
    Apr 4, 2007
    #7
    I'm kind of curious myself. The Default drivers seem to give me very jumpy results.
     
  8. macrumors newbie

    Joined:
    May 31, 2007
    Location:
    Singapore
    #8
    Apple prevented us from downloading the latest drivers, try DH Mobility Modder.
    http://www.driverheaven.net/modtool/

    As the software is for VISTA, download the old version for XP here.

    Download MSXML 4.0 from Microsoft. Link

    Download the latest Catalyst driver. Link

    Run the catalyst installation and let it stop after it extract the files to C:\ATI\SUPPORT.

    Then run Modtool and browse for the catalyst folder in C:\ATI\SUPPORT, it will modify the installation and run for you.
     
  9. macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Darkplace Hospital
    #9
    I'm having a bit of trouble with that installer, it seems to crash a little too much on me!
     
  10. macrumors newbie

    Joined:
    May 31, 2007
    Location:
    Singapore
    #10
    More details?
     
  11. macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Darkplace Hospital
    #11
    I followed the steps for XP, but when I "patch" the drivers it throws an error message at me "cannot find file". I downloaded the latest Catalyst drivers too.
    Might update to Vista if it's less prone to crashing. I'd like a little performance boost in Episode 1.
     
  12. macrumors newbie

    Joined:
    May 31, 2007
    Location:
    Singapore
    #12
    Did you extract the files to C:\ATI\SUPPORT? The name of the folder should look like this, "7-4_xp_dd_ccc_wdm_enu_****".
     
  13. macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Darkplace Hospital
    #13
    Yup. I followed the instructions exactly, then I played around a little (changing folder names, rebooting, changed compatability mode etc) with no luck.
     
  14. macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #14
    The drivers you downloaded were for the desktop X1600 and not the mobility version.

    It's up to the manufacturer of the computer to come up with video drivers for laptops. Usually...
     

Share This Page