Handbrake - dealing with interlaced image...

Discussion in 'Apple TV and Home Theater' started by shorn, Jan 27, 2011.

  1. macrumors regular

    Jun 29, 2010
    Hi all,

    I am trying to rip my Flight of the Conchords boxset, however on the standard ATV2 preset I am getting a pretty bad interlaced picture.

    I have searched a bit through the forums, and it seems as though it is recommended to turn on the "Decomb" filter.

    I have gone into picture settings and put the decomb on to Default. I did a live preview but I am still getting an image like the following...


    Any ideas? Its a PAL DVD.
  2. macrumors regular

    Jan 7, 2004
  3. macrumors 6502


    Jan 22, 2011
    South Central PA
    the deinterlace filter and or maybe try the apple TV (original)
  4. macrumors 65832

    Mr Kram

    Oct 1, 2008
  5. macrumors 65816


    Dec 10, 2002
    Decomb sort of removes the wiggles caused by "soft" interlacing. If you aren't sure if the video is interlaced, supposedly decomb is the best choice. If you see strong "hard" interlacing such as your example above, use the de-interlace option set to slowest.
  6. macrumors 6502a

    Feb 4, 2008
    For my 1st gen AppleTV, I use the AppleTV preset and select the Decomb filter (set to Default). That always seems to take care of interlace issues.
  7. macrumors 6502

    Feb 19, 2006
    For what it's worth... I've never used the decomb filter, have always used Deinterlace Fast and it works fine. Any movie that I question if it will be interlaced, (animated, older movies, or TV Shows from the '80s) I hit the preview button to see if those lines are there.
  8. thread starter macrumors regular

    Jun 29, 2010
    OK, tried last night. Used the Deinterlace setting (fast i think). Its removed some of it but led to quite a jerky playback. Video was not playing smoothly.

    Will try again!
  9. macrumors 68030

    Oct 15, 2008
    Some older DVDs are just terribly mastered. If they have a mix of different material on disk (like CGI and normal film) then they are often not flagged correctly.

    Usually if the material is interlaced you should use:
    -Detelcine - Default
    -Decomb - Default

    Old stuff (like the early Star Trek TNG) that's poorly done breaks due to the Detelcine. For that I do:
    -Detelcine - Off
    -Deinterlace - Slower

    In most cases the top set works well as it's smart and used selectively. The bottom is more of a "dumb" arrangement so it's bluntly applied to everything and can squash detail in scenes that don't need the deinterlacing.
  10. thread starter macrumors regular

    Jun 29, 2010
    OK, tried a few more times, I have tried a few different settings and presets.
    I used High Profile with RF 19.25, and set
    -Detelcine - Default
    -Decomb - Default
    as per the last suggestion. The picture quality is very good. Interlacing seems gone, however the video plays slightly jerky. It is not very smooth.

    This keeps happening everytime I add the picture settings to combat the interlacing.
    Its really bugging me! Thought it would be a straight forward rip. Would just nab it off iTunes but it seems to go for quite a premium at £19.99 for the two series! Bit of a ripper when I already have the DVDs!

    Anymore suggestions?
  11. macrumors 6502a


    Jun 2, 2006
    washington dc
    I'm having the same issues with my Simpsons DVDs using the AppleTV2 preset. I will try the suggestions in this thread... thanks!
  12. macrumors regular

    Apr 16, 2005
    Washington, D.C.
    I used decomb for simpsons (season 1-7) and that worked fine. AppleTV1 preset.
  13. thread starter macrumors regular

    Jun 29, 2010
    Tried again using Decomb and ATV1 preset. Still jerky playback. Bloody things doing my head in!
  14. macrumors 68030

    From A Buick 8

    Sep 16, 2010
    Ky Close to CinCinnati
    I have just used the high profile and left everything else alone and that has worked on the TV shows I was having issues with.
  15. thread starter macrumors regular

    Jun 29, 2010
    Well i'm still out of ideas and without a solution for this one.

    If I use the standard ATV2 I get a nice smooth payback, but with bad interlacing. Anytime I introduce the deblock filter, it deals with the interlacing, but playback is jerky.

    Anymore ideas to try or suggestions why? I've tried pretty much every setting recommended!
  16. macrumors 6502a

    Feb 4, 2008
  17. thread starter macrumors regular

    Jun 29, 2010
    I have, although no one seems to have offered up any suggestions!

Share This Page