Handbrake subtitles help please!

Discussion in 'Apple TV and Home Theater' started by ascender, May 6, 2011.

  1. macrumors 65816

    Dec 8, 2005
    Looking for some help please as this is driving me nuts!

    I have a .mkv file which I'm converting for ATV using the High Profile preset.

    If I open the file in VLC, there's a selectable English subtitles track.

    In Handbrake, I have two options for subtitles, the usual Foreign Audio Search and "0 - Unknown - (Text) (UTF8).

    No matter which one I select and which of the options or combination of options (Forced Only, Burned In, Default) I select, I cannot get the resulting encode to display the english subs.

    Any ideas what I'm doing wrong? I normally don't have these problems so I'm guessing I'm just having a bad day and missing something obvious.....

  2. macrumors 68020

    Mar 27, 2003
    Well, foreign audio search will only select subs if they are flagged as foreign audio, which is not likely assuming you are using an mkv file for your source. So that leaves the UTF8 Track. HB cannot burn text subs tracks in (it should be disabled when that sub is chosen). it can only pass it through as another text subs track. Again assuming you are going to an m4v just pass it through as a subs text track. It should be selectable on the atv then as a soft sub. the atvs both disregard the default flag so you will have to activate it manually in the atv interface. Once chosen the subs will always display when you play said movie unless you turn them off.

    Also, again assuming you are encoding to mp4 make sure the movie ends in .m4v for the atv.
  3. macrumors 6502a


    Oct 5, 2007
    Fort Worth, TX
    The only thing I can think of is that you're pulling from an .mkv instead of a disc or image. I don't ever have those troubles when reading a disc or image, and have never seen an unknown text subtitle.
  4. macrumors 6502a

    Jolly Giant

    Sep 15, 2010
    Hamburg, Germany
    you can activate/deactivate subs - or choose chapters - by pressing (and keep pressing) the select button on the remote while the movie is playing.
  5. macrumors 68020


    Apr 15, 2004
    Washington DC
    If you have the SRT of the subs you want just use subler to add the file to the m4v you created.

    In fact, if the MKV is already h264 no need to use handbrake at all..... Just use subler to re-parse it into a M4V file (If this is for the ATV2).
  6. macrumors 6502a

    Jolly Giant

    Sep 15, 2010
    Hamburg, Germany
    good point !

    MKVtools is another great tool.
  7. macrumors 68020


    Jun 2, 2008
    From reading above, you can get a mkv & srt file and get them working on an ATV.

    Can the merging of the subs so it's readable on the ATV be done if the file you want to convert is NOT a MKV and instead an AVI?
  8. macrumors 65816

    Jan 13, 2008
    As mentioned, for many mkv's, you don't need to use Handbrake for this. Instead, download MKVTools, Jubler, and Subler. Do this:

    1. Extract the .ass subtitles using MKVTools.
    2. Open .ass subtitles in Jubler and re-save as .srt.
    3. Drop the .mkv onto Subler, uncheck the subtitles, then add the .srt file. Save as .m4v. You're done.

    If the video stream inside the .mkv is H.264 level 5 or higher, you'll need to throw it into Handbrake after all to get it to play on the Apple TV 2. Just add the external .srt file you created.

    All that said, the "burn in" option with the single subtitle track you saw listed in Handbrake should have worked, but you'd have burnt-in subtitles.

Share This Page