Hard Drive can't be mounted

Discussion in 'Mac Basics and Help' started by ShadowSKAR, Jan 13, 2013.

  1. macrumors newbie

    Joined:
    Jan 13, 2013
    #1
    After the trial of MacDrive ended, I uninstalled it but I think it somehow affected my partition.

    It's no longer bootable. Going into disk utility from the recovery partition shows it can't be mounted. The options to verify/repair permissions is greyed out.

    The disk can't be verified because "keys are out of order." It can't be repaired either. It gets to "rebuilding catalog B-trees" and tells me it can't be rebuilt.

    I've tried single user mode but it seems to be stuck in my recovery partition. When I list the disks, there's like 7 different disk.

    A friend suggested I try his DiskWarrior disk. After building a new directory, it can't replace the old directory due to "Mac OS services failure."

    What other options do I have at this point to fix the disk? And if I don't, is there someway to get the data off? I did a block by block copy but now that disk has the same problems too.
     
  2. thread starter macrumors newbie

    Joined:
    Jan 13, 2013
    #2
    I threw in the towel on the original disk. Erased and reinstalled OS X. I was intending on using Data Rescue (which has saved me numerous times; highly recommended).

    The backup disk was partially accessible with MacDrive under Windows. But after I started a recovery on the unmountable disk, it showed up in my finder. The previously unaccessible disk somehow got fixed with Data Rescue.

    Any ideas and thoughts on what happened?
     
  3. macrumors 603

    justperry

    #3
    Did you unmount and eject the disk before uninstalling, if not then I think that might have been the problem, windows was maybe busy with it while you uninstalled MacDrive.
     
  4. thread starter macrumors newbie

    Joined:
    Jan 13, 2013
    #4
    I'm pretty sure that's what happened. The disk was somehow in use when I uninstalled MacDrive.

    But do you know why trying to recover data from it somehow made it accessible again when Disk Utility and DiskWarrior failed?
     
  5. macrumors 603

    justperry

    #5
    No, I think this is odd, I until now never heard of a recovery program fixing a HD, some people say Diskwarrior recovers files, it does not, it repairs the directory and after this the files are accessible again, is this recovery, not in my dictionary.

    Recovery scans the disk for files, this is all what they do, so it is indeed strange.
     
  6. thread starter macrumors newbie

    Joined:
    Jan 13, 2013
    #6
    I realized that's basically what DiskWarrior does after I tried it at the suggestion of a friend. But my directories weren't broken in any way as far as I was aware so naturally I didn't do a whole lot.

    I'm thinking that somehow when it was scanning the disk for files, did it somehow fix the access to the disk? MacRescue has saved me numerous times when I accidentally deleted something, but this time... I don't even know what to say.
     

Share This Page