Have to "Airplane mode" to get back service?

Discussion in 'iPhone' started by vampireszombies, Nov 9, 2012.

  1. vampireszombies, Nov 9, 2012
    Last edited: Nov 9, 2012

    macrumors 6502

    May 20, 2011
    I go to class where there is little to no service. The bars go from one to two and once in awhile to No service.

    Once I leave class (where just before class I had 4G full bars) the phone will either stay on low bars with edge or full bars with edge and will not go back to 4G unless I switch airplane mode on then off, resetting the cell signal.

    Also, at the gym (where I had perfect no problem wifi with my 4 and 4S) I couldn't even listen to music because the wifi wouldn't hold, constant skipping disc action! Plus the cell service kept dropping from full 4G to no service! :confused: so once again I airplaned it and it worked after that.

    So are most people experiencing this stuff, where eventually a software update should fix it? Or is it hardware and should I exchange it?

    PS not to mention the battery life being pretty bad. (I don't even get calls or that many texts, and its pretty bad, can't imagine what it's like for people that do get a lot)
  2. macrumors 65816


    Oct 26, 2011
    At the alternatives section.
    inconclusive in my case.

    ive noticed that either shutting down and powering up the phone or turning airplane mode on and off will give me better service immediately after, but would soon go back to poor connectivity in that specific area.

    your battery problem should be related to this - the worst the service the more battery the phone uses.
  3. macrumors 601


    Jul 24, 2008
    Pacific Northwest, US
    The times I noticed my phone dropping off LTE (sometimes all the way to no service) it came back all by itself with no Airplane Mode necessary. It sounds like it may be location related but a Genius appointment to verify the hardware is never a bad idea. :)
  4. thread starter macrumors 6502

    May 20, 2011
    Sorry, should of mentioned I don't have LTE in my area so 4G is the most I get.
    Also genius appt isn't possible since no apple stores locally.
  5. macrumors 68020

    Jun 29, 2012
    Colorado Springs USA for now
    With LTE just starting here in Denver I had noticed this issues. I will have full bars with just ATT showing at the top and it says I have no internet. Turning off and on helps. Saw a guy in the Denver LTE thread say he called att and they did all kinds of things, might need to do that to get it working 100%.

Share This Page