Having trouble setting up a network

Discussion in 'Mac Accessories' started by kjs862, Jun 3, 2006.

  1. kjs862 macrumors 65816

    kjs862

    Joined:
    Jan 21, 2004
    #1
    My house has two macs. A powermac g5 and a iMac g5. My setup is as follows. Cable modem to a router, router to the powermac g5(ethernet cable) and again the router to an airport express (ethernet cable). The imac g5 is located on a different floor of the house so I just installed an airport express card in it. I can connect to the internet fine via airport, but I'm having a problem sharing information between the two computers. Particularly I was hoping to share the itunes music library, and use bonjour messaging. If anyone can help me with this I would be very appreciative.

    Best,
    Ken
     
  2. Bobdude161 macrumors 65816

    Bobdude161

    Joined:
    Mar 12, 2006
    Location:
    N'Albany, Indiana
    #2
    welp, yer half way there. Do you have Personal File Sharing on? It's located in your System Preferences' Sharing option. Make sure you have it turned on on both Macs. when you turn it on you'll get a message on the bottom of the window to type in an address in the Connect to Server window.
     
  3. dextertangocci macrumors 68000

    Joined:
    Apr 2, 2006
    #3
    I have a network with 8 macs, and I use airport extreme, it works perfectly to share files, music and bonjour messaging. All you have to do is:

    Go to system preferences, sharing, and check personal file sharing and if you want, remote login. Do this on both macs.

    Then, to access each computers HD, or cd/dvd or any other external flash drive or ipod etc, click on go in the finder menu, and say connect to server, or just press the apple key (next to the spacebar) and k, and type in the ip address of the mac you want to access.
     
  4. kjs862 thread starter macrumors 65816

    kjs862

    Joined:
    Jan 21, 2004
    #4
    Alrighty, I went to system pref, sharing and enabled personal file sharing. In itunes I have look for shared music enabled on both macs, but still no luck. Any other suggestions ?
     
  5. AlBDamned macrumors 68030

    AlBDamned

    Joined:
    Mar 14, 2005
    #5
    Have you enabled music sharing in the iTunes preferences on both Macs?
     
  6. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #6
    And do you have iTunes running on the mac to be shared? It won't work unless it is.

    Also, your personal firewall on the Mac might be blocking iTunes, but it should tell you what to do if it is.
     
  7. kjs862 thread starter macrumors 65816

    kjs862

    Joined:
    Jan 21, 2004
    #7
    I have share my music library and look for shared music enabled on both macs. As far as firewalls, both are disabled.
     
  8. NJuul macrumors 6502

    Joined:
    Mar 15, 2006
    Location:
    Boston
    #8
    I had a problem similar to this. I fixed it by giving the airport express a manual IP adress (not DHCP), and then disabling "Distribute IP-Adresses" (on the airport express).
     
  9. kjs862 thread starter macrumors 65816

    kjs862

    Joined:
    Jan 21, 2004
    #9

    Alrighty how do I do this? On the imac I'm guessing ?
     
  10. NJuul macrumors 6502

    Joined:
    Mar 15, 2006
    Location:
    Boston
    #10
    On the iMac, open up Aiport Admin Utility.
    Select your network, and push "configure".
    (Select "Internet", and in "Configure", select "Manually"
    Type in your IP adress, your routers IP address, subnet mask, and router address.) <-- Don't know if this part is necessary.
    Select "Network", uncheck "Distribute IP addresses".
    Update.

    Mind you, I'm not really knowledgeable on this, I just had pretty much the exact same problem, and this is how I fixed it.

    Good luck!
     

Share This Page