Having trouble with .sit files

Discussion in 'Mac Basics and Help' started by Jollins, Jun 22, 2006.

  1. Jollins macrumors regular


    Jun 9, 2006
    Is this a problem with the web, or is it my system? Sometimes when I download a .sit file and extract it using Stuffit, the unpacked folder stuffit creates will display 0 files. When I view "Get Info", the folder does contain data, I just can't see anything. It happens with all web browsers.

    This happens with some .sit downloads, but not others. Here is an example of one I have this problem with: http://www.macupdate.com/info.php/id/11790

    Any ideas? This is my first truly confusing software problem as a switcher yay :eek:
  2. JHipp macrumors member

    Dec 28, 2005
    Are you extracting to the desktop? Try creating another folder and extract to there.
  3. XNine macrumors 68040


    Apr 7, 2005
    Why are you wearing that stupid man suit?
    What version of stuffit are you using? This is a pretty common problem when something has been stuffed with Version 10 and unstuffed with version 9, etc. Try updating stuffit to the latest version, or use UnRarX or Split & Concat to open the file. Finally, if none of these work, try using OS X's built in BOM ARCHIVER tool (control click on file>open with>BOM ARCHIVER)
  4. Jollins thread starter macrumors regular


    Jun 9, 2006
  5. elfin buddy macrumors 6502a

    elfin buddy

    Sep 16, 2001
    Tuttlingen, Germany
    I actually often have the same problem too...really starting to piss me off. I've been trying to use .zip exclusively for the last while.

    I've found that using my Classic Stuffit Expander usually works on troublesome .sit files, though I really don't like waiting for it to start up.

    EDIT: Hopefully your solution will work for me...just turned it on then, but haven't had the chance to test anything yet. Thanks!

Share This Page