Headphones jack and Audio not working after OS X Lion Beta upgrade

Discussion in 'Mac OS X Lion (10.7)' started by MetRob24, Feb 27, 2011.

  1. MetRob24, Feb 27, 2011
    Last edited: Feb 27, 2011

    macrumors newbie

    Joined:
    Feb 27, 2011
    Location:
    New York City
    #1
    Hello to everyone,

    I've search around and I haven't found an answer to the following.

    After I upgrade my MacBook Pro to OS X Lion Beta from Snow Leopard the Headphones jack and Audio are not working properly.

    Here's what's happening, see below.

    1 - When I plug in my External Speakers Bose Companion 2 or headphones to the Headphones jack the Audio starts to sound pretty bad. and in order for me to fix this I have to turn of the Mac and re-start it. After the Mac restarts again (with speakers plug in), the sounds goes back to normal. But if I unplug the speakers/headphones from the jack the sounds goes bad again. Once I re-start the Mac again with the Speakers un-plug the sound goes back to normal. But if I plug the speakers/headphones again the sounds goes bad again.

    I just want to double check if any one is experiencing the same issue after OS X Lion Beta upgrade. This wasn't happening before I did the upgrade.

    Can anyone let me know what might be the issue here, I am considering doing a whole system restore back to Snow Leopard to figure out if is a Software related issue or Hardware issue (headphone jack gone bad). I am out of my 1 year warranty and I don't want to even think about is a HW issue.

    Thanks in advance to everyone and appreciate your help and comments on this issue.

    Note: My Brother in-law has a MacBook Pro 13" (2010) running on Snow Leopard and I plug in the Speakers/Headphone and the issue I mention above does not happen to his Mac.

    Thanks,
    Roberto
     
  2. macrumors newbie

    Joined:
    Feb 27, 2011
    #2
    RE: Headphones jack and Audio not working after OS X Lion Beta upgrade

    I have the same problem with my 2010 13" MacBook Pro. The audio will also sound pretty bad after leaving the headphones in without playing anything for a while. Hope there's a workaround.

    Regards,
    Carlos
     
  3. macrumors 601

    ayeying

    Joined:
    Dec 5, 2007
    Location:
    Yay Area, CA
    #3
    I really really hope you guys have a back up copy of your original install.

    This is literally a very early release of Lion, meaning many many bugs. I wouldn't install it over my original.
     
  4. macrumors member

    Joined:
    Mar 19, 2009
    Location:
    ...
    #4
    same problem here

    macbook air 11
     
  5. ovrlrd, Feb 28, 2011
    Last edited: Feb 28, 2011

    macrumors 65816

    ovrlrd

    Joined:
    Aug 29, 2009
    #5
    Easy fix, just go into Audio MIDI Setup and change the output format to 2-ch 32-bit float and then it will stick and you won't have any issues from then on. I suspect that there is something wrong with the default (16-bit) mode that bugs out.

    I always laugh when someone suggests reverting to a backup copy of your OS. I think almost everyone running a beta version of an OS for developers knows what they are getting into and will either live with the bugs or find workarounds. The whole point is to test software to make sure it works and fix the bugs that are broken in your software. If you aren't a developer or are not doing testing for a developer then you really have no reason to be running it (plus it's a really dumb way to spend your money).
     
  6. macrumors newbie

    Joined:
    Feb 27, 2011
    #6
    Thanks ovrlrd! That fixed it for me.
     
  7. thread starter macrumors newbie

    Joined:
    Feb 27, 2011
    Location:
    New York City
    #7
    ovrlrd,

    Thanks for your help. Yes it fixed it for me to as well. I followed your instructions and now the sound is back to normal. I got worried for a minute.

    Thanks again for your help.

    Thanks,
    Roberto
     
  8. macrumors newbie

    Joined:
    Mar 1, 2011
    #8
    I had to register to say thanks.
     
  9. macrumors newbie

    Cruleworld

    Joined:
    Feb 13, 2009
    #9
    Thanks so much, this was the only thing driving me nuts
     
  10. macrumors newbie

    Joined:
    Mar 2, 2011
    #10
    Help!!!

    How do you do that? "Easy fix, just go into Audio MIDI Setup and change the output format to 2-ch 32-bit float and then it will stick and you won't have any issues from then on. I suspect that there is something wrong with the default (16-bit) mode that bugs out.
    "
     
  11. macrumors newbie

    Joined:
    Mar 3, 2011
    #11
    Complete solution

    Go to Applications -> Utilities -> Audio MIDI Setup (a Spotlight search for Audio MIDI Setup is ok too)

    There change your output to 32 Bits and you're done!
     
  12. macrumors newbie

    Joined:
    Sep 4, 2010
    #12
    ovrlrd you are a genius!!!1
     
  13. macrumors newbie

    Joined:
    Jul 17, 2007
    Location:
    Louisville, KY
    #13
    Fix Found

    I confirm ... this worked for me as well.
     
  14. tanhm, Jun 9, 2011
    Last edited: Jun 9, 2011

    macrumors regular

    tanhm

    Joined:
    Jun 7, 2011
    #14
    after upgrading to Lion beta, my headphone does not work , speaker is fine, I did what ovrlrd suggested, however , it still can not

    any other suggestions

    thank for your help


    @work after restarting . Tks
     
  15. macrumors newbie

    Joined:
    Jul 30, 2011
    Location:
    Quetzaltenango, Guatemala
    #15
    i don't have 32bit

    hi, i've a MB 2008 black, and don't have 32bit option. do you have the solution?
     
  16. macrumors newbie

    Joined:
    Jan 23, 2010
    #16
    Don't have 32 bit either...

    I have a MacBook Pro and the highest option is 24 which it is already on. No dice.
     
  17. teobesta, Oct 2, 2011
    Last edited: Oct 2, 2011

    macrumors newbie

    Joined:
    Oct 2, 2011
    #17
    my imac also doesn't have the 32-bit option. max is 24. this is frustrating.

    [edit a few hours(!) later. ugh!]
    this worked for me, got my "headphones" back & control over the computer's main volume control
    without the greying (which picked my curiosity & got me in trouble to begin with)
    http://forums.macrumors.com/showthread.php?p=13445650#post13445650
     

Share This Page