1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Hell YES! Anyone catch this!

Discussion in 'iCloud and Apple Services' started by Edrubin, Jul 12, 2008.

  1. macrumors member

    #1
    SO a lot of people were griping about how mobileme could only have other emails forwarded to it and you couldnt respond with the actual email address such as gmail. I just checked and if you are on your iphone and clock the from area a click wheel pops up and allows you to choose which email you want to reply from! This is great!
     
  2. macrumors regular

    ViveLeLivre

    #2
    Yeah, you can do the same thing from mail.app too. I'm not sure about the web interface.
     
  3. macrumors newbie

    #3
    yea

    but who the hell wants to have to remember to do that everytime they send an email?
     
  4. macrumors 65816

    hotwire132002

    #4
    You are seriously brilliant -- even though I was aware that Mail on both my Mac and iPod would allow me to reply to an email that was sent from one address using a different address, I had never though of using it with MobileMe this way.

    Thanks for a great idea -- As soon as I get MobileMe working right with my laptop, I'm going to forward all my email addresses to my MobileMe account and just reply from my other accounts!
     
  5. macrumors newbie

    #5
    You can also set any smtp mail server as the default so that you don't have to switch every time you send an email.
     
  6. macrumors 68020

    juanster

    #6
    yeah in mail ihave it set up so thata ll my mails are sent from one address and teh rare one that i want to send with a different one, well its just a couple of clicks away just to change the outgoing mail address...
     
  7. macrumors newbie

    #7
    I have a question: What is the difference/advantage of forwarding email to mobileme vs. having mobileme check or pull email from that other account?
     
  8. ukp
    macrumors newbie

    #8
    Could you post instructions on how this works, because I cannot get this to work. Thanks.
     
  9. macrumors member

    #9
    Instructions

    It's very easy. In your gmail account (From web browser) click settings. Then click the "Forwarding Tab" It should be the first one that says to have gmail forwarded to a specific email address. type in your mobileme address then choose to keep in inbox, archive, or delete. I prefer archive so it keeps it in the gmail server, but does not put it in the inbox so your iphone doesn't go off twice for the same email.

    Then on your iphone you will get all gmails forwarded to mobileme and when you click reply click the "from" area and it will let you choose to use another email address that is on your iphone. It's great.
     
  10. macrumors regular

    ViveLeLivre

    #10
    It doesn't show up as a forward.
     
  11. macrumors newbie

    #11
    Is there any way to setup gmail like you can in mail.app on leopard where you can set the email address seperated by commas and be able to choose from the list to send from?
     
  12. macrumors member

    #12
    I was excited by this, as I thought it'd let me choose the alias address I have under the main account name on my family me.com account, but it only offers my main account names, not any of the alias addresses I have set up for those accounts.

    So, my question is, should (or can) I set up an alias account to work as the sent from and reply to address?

    Thanks. Joel.
     
  13. ukp
    macrumors newbie

    #13
    Ok, I already have a forward setup on gmail to my @me.com address. This has been working fine. When I click on reply, there is no From field. Just To and Subject.

    Can someone else confirm they got this working because I am feeling quite stupid atm if it really is as easy as posted.

    Edit: Do I need to setup a gmail account on the iphone mail app also?
     
  14. macrumors member

    #14
    Instructions

    You will need your gmail account set up on the phone as well. Also make sure under mail settings that you have it showing the "from" field in emails.
     
  15. macrumors member

    #15
    this is a good feature, I just discovered it myself today as well.

    The only thing I would recommend is setting gmail to automatically archive any mail it receives do it doesn't sit in the inbox (gmail & the iphones) and basically show up as a duplicate.

    EDIT: Another good thing about this is that you can delete the email from mobile me as it is saved on GMail servers as well....so you can allocate the majority of the 20GB to iDisk
     
  16. macrumors newbie

    #16
    Great Idea!!! i love it! Is your push moving quick right now? I would think it would show seconds after hitting send...I suspected it would move like a blackberry i.e. quick as a text...are you having this same issue?
     
  17. macrumors member

    #17
    Reply

    Mine is pretty quick. It changes from each email. I've been testing it and sometimes its instant and other times it takes a second.
     
  18. ukp
    macrumors newbie

    #18
    Ok, I have now got it working. I have disabled forwarding on gmail. Instead I created a filter that skips inbox, adds a label called My Mail and then forwards to my @me.com address. I also added a rule to stop mailing lists from being sent also.

    On my iPhone I created an 'Other' account and entered my own personal domain name email address and set smtp and imap to gmail. I then went into Settings->Fetch New Data->Advanced and changed the fetch settings for my domain email to manual. Effectively disabling it.

    I can now select from 2 email address's for replying and my non me.com replies get sent to google for archiving and I don't get 2 new mail notifications for each new mail message. Only one mailbox is polled for new mail (me.com push) and I'm very happy :)

    Thanks you Edrubin for posting a great tip!
     
  19. macrumors 6502

    #19
    This is a brilliant tip, thanks.
     
  20. macrumors newbie

    #20
    Push Working fine?

    Alright I've set everything, I sent a test e-mail and the phone will not notify me that I've received an e-mail. Of course when I open mail on the phone it pulls the e-mail in at that point.

    Things I've checked that seem to be in place properly:
    -"Fetch New Data" set on push. If you click on that button and go under the advanced tab, I have Gmail set on Manual, and @me set as push.
    -"Mail, Contacts, Calendars," by clicking on @me account mail, contact, calendars, bookmarks all say "on."
    -As someone mentioned earlier about changing smtp, such that when you reply to an email from the @me account, you can reply from another address. So under account info my outgoing server is smtp.gmail.com


    As I said, I feel as though everything is in place. Any reason why I'm not getting e-mails instantly on my phone? Could apple still be experiencing issues?
     
  21. macrumors member

    #21
    Need your guy's help now!

    SO Originally I created my mobileme email on the iphone. I then decided I wanted to have it in apple mail on my imac as well. I created it in apple mail and then i went to itunes to sync that email and delete the one i originally did on my iphone, but on itunes it shows @mac.com not @me.com and after i synced it on my iphone it was @mac.com. Why would it do that???
     
  22. macrumors newbie

    #22
    In system preferences does it say .Mac or MobileMe under "Internet & Network?" If it says .Mac, you'll need to click it, and when I did so, a message popped up notifying me that there was an update available.
     
  23. macrumors member

    #23
    It says Mobileme
     
  24. macrumors newbie

    #24
    When you plug it into itunes, under the info tab, my contacts says "your contacts are being pushed to your iphone over the air from MobileMe." The same thing for Calendars.

    Now I did not check the "sync selected mail accounts" under Mail Accounts. Did you check that?
     
  25. macrumors member

    #25
    I no longer check it and just created it on my phone and apple mail but don't sync them, which means i can't sync the folders I create, but thats ok. It is jus tweird that itunes says @mac
     

Share This Page