Help! 12" PB hard disk on its death bed?

Discussion in 'Macintosh Computers' started by mrjamin, Nov 17, 2004.

  1. macrumors 65816

    mrjamin

    Joined:
    Feb 6, 2003
    Messages:
    1,161
    Location:
    Strongbadia
    #1
    Hey,

    I have a 12" PB (miniDVI, 1GHz G4, 768MB RAM, 40GB HDD, AE, BT, combo). Over the last few days, its been running very slow, and has beachballed until its required a hard reset to get it back again. I've repaired permisions, reset the PRAM, verified/repaired the disk, but to no avail. I'm currently reinstalling OSX from the software restore DVDs, and its taking hours! Its been running for nearly 2 hours now, and still only 27% of the way through "Processing BSD Subsystem".

    Why do I think its my hard disk? Because it seems to be doing a lot of 'extra' work. Even on idle, the harddisk is (was) whirring and clicking a lot - no 'abnormal' noises, just as though it was 'doing' something. HDD intensive tasks seem *a lot* slower (searching, indexing my email, copying to/from NFS mounts). Also, its recently starting showing the folder with the question mark in it on boot for a second or so every time, without fail. Other times, its stayed for 10-15s, or thrown a kernel panic part-way through booting. Any suggestions? I've backed up all my data, and just doing a clean install of OSX, so we'll see what that does.

    Thanks in advance,

    mrJ
     
  2. macrumors 68030

    Joined:
    Nov 16, 2004
    Messages:
    2,627
    Location:
    Cloud 9 (-6)
    #2
    It doesn't sound like your OS is messed up, it sounds like your disk itself needs to be replaced. You said you have your things backed up already, so that is good. I would look for a new drive asap and plan on getting it installed and starting over. When harddisks start acting like that, there is usually little that can be done. Best of luck.
     
  3. macrumors 65816

    mrjamin

    Joined:
    Feb 6, 2003
    Messages:
    1,161
    Location:
    Strongbadia
    #3
    ah crap. i was hoping I wouldn't hear that. Oh well, atleast its within warranty. Just bought my first home, washing machine got delivered, turns out its faulty, getting married in 2 days - our honeymoon reservations have disappeared at their end, so all in all, I'm a tad stressed! This is the last thing i need!!

    Ah well, atleast I've still got all 4 limbs intact...
     
  4. macrumors 6502a

    timnosenzo

    Joined:
    Jun 21, 2004
    Messages:
    888
    Location:
    ct, us
    #4
    eh, I say try to wipe the HD clean and reinstall. Usually when a HD is physically damaged it will make noise (in my experience, anyway).

    Good luck (and congrats on your marriage),

    Tim
     
  5. macrumors 68030

    Joined:
    Nov 16, 2004
    Messages:
    2,627
    Location:
    Cloud 9 (-6)
    #5
    I agree with Tim here however I have had multiple silent deaths in my computing time as well, so I never rule that out. The activity of the drive just reminded me of some of the ones I had to retire. Before you call it in and scrap it, it would be worth trying to do a diskrepair and then reinstall and see what happens. If the disk is faulty you should figure it out pretty quickly.
    I guess if its mostly a speed issue, there could be something wrong with the ATA channel, but that would be pretty strange.
    Try the repair and reinstall, hope it works for you.

    Congrats on the marriage, I hope the honeymoon stuff works out well :D
     

Share This Page