Help an old guy?

Discussion in 'Mac Basics and Help' started by rjf, Jan 3, 2007.

  1. rjf macrumors newbie

    Joined:
    Jan 3, 2007
    #1
    Hi,
    I have a G4 Powerbook.
    Keyboard shortcuts seem to be a problem for me. I have a mighty mouse but like to use the keyboard shortcuts for Expose (f9 10 11). I configure this in preferences and then when I start up they don't work; I have to access system preferences and reset the defaults again. Is there some way of locking the preferences? or am I doing something wrong?
    Thanks in advance...
    Robert
     
  2. Legolamb macrumors 6502a

    Legolamb

    Joined:
    Nov 27, 2006
    Location:
    North of where I'd like to be
    #2
    Re: prefs not being saved

    Try "repair disk permissions" from the Disk Utility application
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Do they work immediately after you change them or do they need the FN key? :)
     
  4. 2nyRiggz macrumors 603

    2nyRiggz

    Joined:
    Aug 20, 2005
    Location:
    Thank you Jah...I'm so Blessed
    #4
    Are your settings being saved or is it everytime you open up the system prefs it reverts back...repair permissions(recommend) could be the problem solver or moving the plist file could be another.



    Bless
     
  5. iSaint macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #5
    Right as usual, madman. With the G4 Powerbook, you use fn-F9 and fn-F10 as your hot keys for Expose'. F11 should give you a desktop view without the function key. The F9 and F10 keys are for your keyboard brightness when they are backlit.

    However, under System Preferences>Keyboard, you can select the "Use the F1-F12 keys to control software features" button, and you won't have to use the function key for Expose'. But, you will for brightness, volume, and keyboard brightness functions.
     
  6. rjf thread starter macrumors newbie

    Joined:
    Jan 3, 2007
    #6
    Thanks everyone...

    Hmmm... well it's a bit like when the tv repair man comes... and the tv works! I booted up this morning and it was ok. The F keys were as I had set them. In response to your suggestions I repaired my permissions, and in reply to 'madjew', no, I don't have to use the fn key to work them.
    I guess I messed about with the Dashboard and Espose/ Keyboard and mouse preferences yesterday so much that I didn't know which end was up. Funny though that for ages now I have had to do a restore default settings every time I booted up to get the F9 etc. keys to work and this morning it's ok... It's all a mystery - maybe this site is so good it fixes problems by just having them published...!
    Thanks again to all who helped... Happy New Year.
     
  7. Mac'Mo macrumors 6502a

    Mac'Mo

    Joined:
    Aug 29, 2006
    Location:
    NYC
    #7
    once you set your preferences, they should be saved
     
  8. someguy macrumors 68020

    someguy

    Joined:
    Dec 4, 2005
    Location:
    Still here.
    #8
    In my experience, keyboard shortcuts other than the defaults for Expose and Dashboard don't seem to stick unless you change them in either/both the "Keyboard & Mouse" and "Dashboard and Exposé" preference panes.
     

Share This Page