Help! Brand New Apple TV not showing up in iTunes!

Discussion in 'Apple TV and Home Theater' started by Sdao, Feb 24, 2008.

  1. macrumors 6502

    Joined:
    Jul 12, 2007
    #1
    Hey guys, I just bought my Apple TV yesterday, i synch'd it with all of my songs yesterday and it successfully transferred half of my content to the apple tv. I stopped it from synching as i was going to bed, and was planning on synching the other half of my content this morning.

    Now, this morning I turn on my computer, launch iTunes and my AppleTV is not showing up. I've restarted my computer, re-connected my AppleTV to the internet, etc... I've done everything that I can think of doing.

    Has anybody had this problem/know what to do?

    Thanks
     
  2. macrumors 68000

    Much Ado

    Joined:
    Sep 7, 2006
    Location:
    UK
    #2
    I think if you go > Preferences > Apple TV there's a check box to 'search for Apple TVs'. Make sure the ATV is switched on, and they should see each other.
     
  3. macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #3
    I've also found that with the way I have my firewall set up when iTunes opens a confirmation box pops up asking if I want to allow iTunes to accept incoming traffic. As soon as I click on yes the Apple TV shows up.

    Make sure you aren't missing that little window. It can get hidden behind other windows.
     
  4. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #4
    I just checked, ATV is on and it is recognized. I see it in the box and to the right of it, it says "synching".

    However, I still don't see it in my itunes.
     
  5. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #5
    I dont have a firewall set up and I dont see a popup box.

    :(
     
  6. macrumors P6

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #6
    Huh? If you see it synching are you seeing that in iTunes or on a TV ?
     
  7. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #7
    I pulled the plug on the ATV, as per Apple troubleshooting guidelines.

    After waiting 30 seconds and plugging the ATV back in, it is now being recognized and synching the remainder of my music.
     
  8. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #8
    It said it was synching under the itunes preferences box, however it wasn't showing up on my itunes library.

    weird.
     
  9. macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #9
    I got this same issue!!! 3 days out of the box....happened everynight.

    The only thing that works is unplugging the apple tv box and restarting itunes.

    I've done everything from going to preferences>find apple tv ... reinstalling itunes, repairing disk permissions, reinstalling my airport.
    I even tried not syncing just streaming and it still did it.

    I have no firewall. all up to date software.
    After about 3 hours it disappears from itunes if its not being used and won't comeback until i unplug it.
    What a pain in the @$$.
     
  10. macrumors 6502a

    Joined:
    Aug 28, 2007
    #10
    I had a similar situation that I posted yesterday. I still haven't found a solution. My next step is to turn of the software firewall so I can determine if it's the router or the software.
     
  11. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #11
    Good to know that there are other people out there looking into this problem.

    Its really upsetting, my AppleTV isn't even 24 hours old. I love the thing thus far, streaming my music and movies to my brand new 50'' bravia is unreal.
     
  12. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #12
    Hopefully its not my wireless router, I have an Apple Airport Extreme...
     
  13. macrumors 6502a

    Joined:
    Aug 28, 2007
    #13
    I must be retarded...

    I think this was the "fix"...when you are trying to link up with your iTunes library make sure you have the ATV on one of the two library options (access share or sync) where the code is displayed. Once I left it on that screen and came back in the room it was in the device list and the screen was waiting for the passcode.

    :eek:
     
  14. macrumors regular

    Joined:
    Jul 18, 2002
    #14
    have you seen this?

    http://www.macfixit.com/article.php?story=20080222120702289
     
  15. macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #15
  16. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #16
  17. thread starter macrumors 6502

    Joined:
    Jul 12, 2007
    #17
    Which of these problems are you experiencing?

    Currently, my AppleTV just wouldn't show up until I unplugged it and plugged it back in.

    The link doesn't really provide any help with that problem... any ideas?
     
  18. macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #18
    Oh i misread it.... I have the problem that you have: where it doesn't show up until i unplug and re plug in the apple tv to get it to show up.

    I thought the article was saying hold down shift for it to find the library for the apple tv...but it was related to another issue
     
  19. macrumors 6502

    Joined:
    Sep 6, 2007
    #19
    Hey guys just so you know if you try to restore original firmware to the atv you will lose everything thats on it included purchased tv shows, so make sure you have a backup!
     
  20. macrumors demi-god

    VideoFreek

    Joined:
    May 12, 2007
    Location:
    Philly
    #20
    Happens to me (and others) all the time when using a wireless network connection ... other threads here and in the Apple support forums have discussed this problem. It seems to happen to me mostly when my network is saturated (i.e., when I'm simultaneously downloading large video podcast files and syncing the Apple TV at the same time). The Apple TV just drops off the network, and won't rejoin until I power it down and restart it. All things considered, a fairly minor annoyance (happens 1-2 times/month), but since I can get a wired ethernet line to my Apple TV, I will probably do this at some point and hopefully get better stability.
     
  21. macrumors 6502a

    Joined:
    May 18, 2005
    Location:
    ATL
    #21
    Mine disappears every night with no network use.
    The computer doesn't even sleep.
    Last thing i tried was downgrading to 7.6 not 7.61 but it still disappeared from devices.
     
  22. macrumors newbie

    Joined:
    Oct 30, 2007
    #22

Share This Page