Help, cannot search

Discussion in 'macOS' started by mdt562, Mar 28, 2006.

  1. mdt562 macrumors newbie

    Joined:
    Mar 28, 2006
    #1
    ok heres the deal, when i use the search feature, nothing pops up. I just type and nothing pops up. Same with spotlight, This has happened before and i just reinstalled my system. One week later it happens again. And i did not install any other program to affect this.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Try reindexing your hard drive by going to the Spotlight section of System Preferences, selecting the Privacy tab, adding your hard drive, closing System Preferences and then use the same method to remove you hard drive from this pane. It'll take a little while to reindex (depends on the machine and the number of files).

    If that doesn't help, then delete a file named com.apple.spotlight.plist from your Preferences folder and restart. :)
     
  3. mdt562 thread starter macrumors newbie

    Joined:
    Mar 28, 2006
  4. mdt562 thread starter macrumors newbie

    Joined:
    Mar 28, 2006
    #4
    ok...it doesnt let me drag my hard driver in to the privacy list :confused:

    EDIT: ok i tried other folders, drag and drop, but see nothing on the list.
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Are you using the little plus sign to add it? Does it give you an error message?

    Oh, and you might be interested in this thread. :)
     
  6. mdt562 thread starter macrumors newbie

    Joined:
    Mar 28, 2006
    #6
    thanks for the effort, but still doesnt work. I would have done a simple reinstall but im in the middle of an imovie project... anyone knows where the Spotlight v100 directory file is?? .... i cant search for it... lol

    EDIT: o yeah, i did use the + sign and it doesnt give me an error msg, it just does nothing when a choose my hard drive or drag my hard drive to it, thx
     
  7. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #7
    That Spotlight file is hidden. Try copying and pasting the following into Terminal in the Utilities folder:


    Code:
    sudo rm -ri /.Spotlight-V100 

    It'll ask for an admin password and then it'll ask for confirmation on removing about eight or nine files. Type y for each one. Once done, type exit and then quit Terminal and reboot the machine.

    Alternatively, use an app like Cocktail to view and delete the hidden V-100 files. :)
     
  8. mdt562 thread starter macrumors newbie

    Joined:
    Mar 28, 2006
    #8
    Thanks! it works now, you saved me alot mad jew really appreciate it. Im sure others will too.
     
  9. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #9
    No worries. I'm glad it's all functioning normally. :cool:
     
  10. aussie_geek macrumors 65816

    aussie_geek

    Joined:
    Apr 19, 2004
    Location:
    Sydney Australia
    #10
    This is an old thread but wth. Helped me!!


    Fixed mine - had probs with my spotlight.

    Did all the add / delete items from spotlight and deleting plist and didnt help till i entered
    Code:
    sudo rm -ri /.Spotlight-V100
    into the terminal and answered yes to everything.:):)
     

Share This Page