Help..Can't turn off int. mic when using garageband...

Discussion in 'Mac Apps and Mac App Store' started by erwanda55, Jan 12, 2005.

  1. erwanda55 macrumors newbie

    Joined:
    Jan 12, 2005
    #1
    Hoping someone will help me with a stupid but picky question......I have garageband 1.1.0 on a iMac G4 10.2.8. I've recorded a song on a Yamaha keyboard (psr 350) put it on a floppy disk (ok, it's a little old) run a cord from the earphone jack on the keyboard to Mobilepre into channel 1 instline. Then I have a usb going into my computer. I used this to transfer simple keyboard stuff before the new year-worked great- and I am now completely confused.

    I don't seem to be able to turn off the internal mic on the computer (have gone into sound window in system preferences and see my mobilepre listed and click on it, go to garage band track info and click on real instrument, basic with no effects and it still is recording from the room) Ok, why can't I turn off the stupid internal mic?

    I'm a music teacher and was feeling so smug about being able to make quick cd's for small projects. URGH....

    Thanks
     
  2. JonoColesUK macrumors member

    JonoColesUK

    Joined:
    Jan 23, 2005
    Location:
    London UK
    #2
    Hy there

    I had the same problem at first

    The way to turn the internal mic off is as follows:

    Open system preferences

    Click Sound

    You'll be met with a box that says "Chose a device for sound input"

    Select "line in" or "Audio line in port"

    hope that helps :)

    Jono
     
  3. Slimjimbo macrumors newbie

    Joined:
    Oct 28, 2007
    #3
    I'm having the same problem - but this solution doesn't work

    Hi, I've just purchased a Firewire solo to do some home recording - but I'm not getting the basics to work. I can't seem to get my Macbook to stop using the internal microphone for input instead of the 'Firewire Solo Multichannel' which is what I have chosen in the sound control panel for sound input.

    Any ideas? Is this a problem with my Macbook?

    Thanks.
    jim
     
  4. Slimjimbo macrumors newbie

    Joined:
    Oct 28, 2007
    #4
    I get the same problem wether my input is guitar or mike

    I've still unable to turn off the internal mike - bloody frustrating. I though this problem was just related to using the an external microphone but even when I input from my guitar I am having the same problem.

    I'd appreciate any help with this.

    Jimbo
     
  5. calculus Guest

    calculus

    Joined:
    Dec 12, 2005
    #5
    Did you try what JohnoColesUK suggested? You have to do this in the System Preferences not in Garageband.
     
  6. Slimjimbo macrumors newbie

    Joined:
    Oct 28, 2007
    #6
    Ok - sorted

    I've now got it working. The problem with the microphone was that the output of the microphone I was using was too low - which meant the Macbook was defaulting to the internal microphone. I'm sure this must be a problem that many people have come across - and many perhaps abandoned their home music recording career at that point - as I can't imaging I would have figured this out myself. :confused:

    The guitar problem was because I had forgot to set the preference for Garage band to use the external input when creating a new project. Given that I've only started up Garageband on three or four occasions - I'll forgive myself for that one.:)

    Thanks for the help.
    Jimbo
     

Share This Page