Help! Diablo 2 Fatal Error!!

Discussion in 'Games' started by Littleodie914, Apr 2, 2006.

  1. Littleodie914 macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #1
    Hey guys, I'm having problems with Diablo 2: LOD. Whenever joining or creating a multiplayer game, I get a fatal error that says... "Unrecoverable internal error 01162bd8 line 855". I have this problem on all my macs, and I've tried everything to fix it. I've reinstalled, patched, made new characters, all to no avail. Single player works fine, and my characters work on my PC, the problem just crops up on my macs. I'm running Diablo version 1.11b and Tiger 10.4.5. I've e-mailed blizzard, but have yet to receive a reply that addresses my specific question. Does anybody have a solution to this? Please help! :eek:
     
  2. Demon Hunter macrumors 68020

    Joined:
    Mar 30, 2004
    #2
    Okay, you installed on more than one Mac, so that means it's not a bad sector on the hard drive.

    If I remember correctly, D2 requires the CD to play. It's probably your CDs. The data could be corrupt, or there's a well-placed scratch.

    I suggest you click here, and for $10 you get newly pressed CDs. :)
     
  3. Littleodie914 thread starter macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #3
    Ah bugger... Well I guess that's kinda better than it being a Mac bug? :rolleyes:

    I've got the .toast images I saved a while back onto my ext. HD just for an emergency such as this, maybe I'll try installing from those instead of the physical copies. Thanks a bunch! :)
     
  4. Demon Hunter macrumors 68020

    Joined:
    Mar 30, 2004
    #4
    Yeah, try those first. :) I did that for original Diablo, but I was unlucky and my .img file was corrupt too.
     
  5. Littleodie914 thread starter macrumors 68000

    Littleodie914

    Joined:
    Jun 9, 2004
    Location:
    Rochester, NY
    #5
    Hmm... Reinstalled with the .toast images, and the same thing's happening. I did a bit more experimentation though, and found that...

    I can't do ANYTHING online with the expansion characters. (Druid + Assassin)

    I can join and create games with original characters, but only when "Save + Exiting" does the game crash. (Though it does save properly.)

    Any ideas? Am I the only person with a Mac playing Diablo 2 who is having this problem? If so, I might consider sending those CD's into Blizzard and getting scratch-free copies sent back...
     
  6. Demon Hunter macrumors 68020

    Joined:
    Mar 30, 2004
    #6
    Does the single player mode have the same problem?

    If so, I still suspect the CD data. If it's only a battle.net problem, then maybe it's the software after all... are your Macs running the same version of OS X? Did you install or move anything?
     
  7. a2daj macrumors member

    Joined:
    Sep 14, 2004
    #7
    How did you update? Did you use the built-in functionality or download a manual patch? There are two updates for Diablo II. One for standard DII and the other for the Expansion pack. Your problems with the expansion pack characters point to the wrong update being installed. The fix is to download the expansion pack upgrade.

    Go here:
    http://www.blizzard.com/support/?id=mdt0387p

    And download the patch under the [Expansion] column. It'll also mention LoD in the file name.
     
  8. Demon Hunter macrumors 68020

    Joined:
    Mar 30, 2004

Share This Page