Help! Dual Quicksilver randomly stops powering USB

Discussion in 'Macintosh Computers' started by thabridawg, Jan 22, 2004.

  1. thabridawg macrumors member

    Aug 16, 2002
    Ever since two days ago... my comp has randomly stopping powering my keyboard and MS Intellimouse Explorer. I've been using the comp with the same keyboard and mouse for about over a year now.

    I start using my comp for 10 minutes, and everything's fine. Then eventually the red LED on my mouse flickers on and off, but the keyboard still works. Then a minute later after my mouse completely goes out, my keyboard goes out too.

    Any ideas on what could go wrong? I haven't opened my Mac in a long time, and I haven't installed any apps or updates in a long time except the recent iCal upgrade, but that's it.
  2. yamadataro macrumors 6502

    Flickering sounds like a bad electrical connection.
    Try other USB ports on your Mac or Keyboard?
  3. thabridawg thread starter macrumors member

    Aug 16, 2002
    hmm... the LED on my mouse is constant for 10-15 mins... then starts flickering, then shuts completely off.

    i've tried several different combinations of usb port connections.... my keyboard and mouse are the only usb devices i use.

    it could be electrical, but i have a $120 Belkin UPS w/ backup...
  4. yamadataro macrumors 6502

    I keep wild-guessing, but maybe the mouse is dead?
  5. thabridawg thread starter macrumors member

    Aug 16, 2002
    could be... but the keyboard stops working as well...

    i'll swap mice w/ my other comp for now and see if the problems still happen
  6. krimson macrumors 65816


    Oct 29, 2003
    Democratic People's Republic of Kalifornia
    if you change the mouse, and it still does that, try and use another keyboard. also check that the connectors aren't dirty or become loose.

Share This Page