Help! How do I change the default outgoing mail account?

Discussion in 'Mac Basics and Help' started by motulist, Jun 1, 2010.

  1. macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #1
    In mail.app I have it setup to use 2 email accounts, one is my personal email account and the other is my business account. How do I set it so that when I create a new email it'll always default to being sent my personal email account rather than my business account? At the same time, I want it setup so that when an email comes into my business account and I hit "reply" to that business email I obviously want that reply to be sent out from my business account.

    How the heck do I do this? I looked through all the preferences and account settings and I couldn't figure it out.

    Help!
     
  2. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
  3. thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #3
    Thanks, but that older tip doesn't work in the newer version, as it states in the article you linked to. Let me describe what I mean. When mail.app happens to be on an email that was sent to account B, then when I hit apple-N it will always create a new mail set to account B as the "from sender" account, regardless of the order that the accounts are listed in my preferences.

    Basically, I want it to work like it said the old version works. The new way it works just sets the sender account to be whatever email happens to be selected at the moment, which is ridiculous. How on earth could they have decided that people don't need a default "send from" account setting?!

    Surely there MUST be some way to set a default sender account!
     
  4. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    That's strange. For me, no matter what mailbox or message I have highlighted, when I click "New Message", it always puts the same account as my default From: account.
     
  5. thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #5
    Really? Because the apple support doc you linked to says it's not supposed to work that way. (assuming you're not using OS X 10.1!)

     
  6. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    I know! Since I posted that link, I've tried rearranging, renaming, logging in/out, clicking on messages/folders, etc. No matter what I do, when I click New Message, I always get the same account in the From: field, even though there are 6 active accounts to choose from. Fortunately, it's the account I want it to use, so I'm not too interested in "fixing" what ain't "broke".
     
  7. thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #7
    Hah, okay, well that's great for you! ;) :( Do you have any idea how this might've come to be for you?
     
  8. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    I'm still working on it. I do know that the default account is the first one added to Mail, so I don't know if it uses accounts in the order in which they were added. That wouldn't make sense, but I'm grasping here.
     
  9. thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #9
    Is it possible that you don't have OUTGOING smtp servers set for your other accounts? I would guess that if you only ever send out emails from a single account, then maybe that's the only outgoing server you ever setup.
     
  10. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    No, I have a different outgoing server set for each account.
     
  11. Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #11
    Preferences > Composing > Send new messages from: ?
     
  12. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #12
    Where's my dunce cap? :D I must be having a "senior moment".
     
  13. thread starter macrumors 68040

    motulist

    Joined:
    Dec 2, 2003
    #13
    THANK YOU!!! :D That did it! :) I don't know why I didn't think to look there. I wonder why this isn't the default setting, because it seems so much more logical and natural than having it seemingly change at random.

    I think mail.app's prefs design could do with a little refining.
     

Share This Page