HELP!!! iBook G3 900mhz 12.1"

Discussion in 'Macintosh Computers' started by hob, Nov 26, 2003.

  1. hob macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #1
    I have a 900mhz G3 12.1” iBook, which I ordered in August 2003 through the Apple UK Store.

    It has been running perfectly fine for the last few months, but today I took it on a train, which is where my trouble started. I opened the lid to wake it up, and used it for a few moments. After a minute or two, the screen flickered slightly and some lines appeared. Then, the whole screen started to fill with lines of odd colours! I promptly turned it off, folded it up, and put it back in my bag.

    When I returned home, I plugged it into the mains, and powered it on. The machine started but the screen did not come on. I turned it off and tried again a few times, eventually the screen came on. It started to loads OS X, and then the screen filled with the similar lines, and the loading-gear stopped spinning on screen. I turned it off and tried again, with similar results.

    I inserted the OS X install CD and ran the disk check utility from the install program, checking first the permissions and then a full disk repair. I then rebooted to find that after a considerable amount of loading time, it booted into OS X. After a few moments, however, the same screen errors appeared.

    As a student of IT and an experienced computer user, I am completely baffled!! Can I fix this problem, or does it need to be returned?
     
  2. CmdrLaForge macrumors 68040

    CmdrLaForge

    Joined:
    Feb 26, 2003
    Location:
    around the world
    #2
    Re: HELP!!! iBook G3 900mhz 12.1"

    Return it ! You still have warranty.

    Cheers
     
  3. hob thread starter macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #3
    Follow up:

    I called Apple Support UK, and this lovely irish woman told me to hold Ctrl, Alt, Shift and the power button. I am now typing this from my iBook, so everything seems to be better..... for now....

    Hob
     
  4. hob thread starter macrumors 68020

    hob

    Joined:
    Oct 4, 2003
    Location:
    London, UK
    #4
    I put it to sleep a coupla times and when it came back it never loaded back properly, so i turned it off. Now when i turn it on, the screen doesn't work at all!!

    HOW do I go about sending it back??

    Hob
     
  5. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #5
    It'll be worth your while sending it back. it sounds like a faulty logic board - seems to be a problem with some iBooks for some reason. Apple will replace the board for free but you never know, they may return a brand new iBook G4!

    It's a bit of an arse here in the UK because you can't just walk into an Apple store. I'd ring them and they should tell you want to do or where to send it to.

    I'm hoping that nothing goes wrong with my new PowerBook!
     
  6. celaurie macrumors 6502a

    celaurie

    Joined:
    Mar 2, 2003
    Location:
    Edinburgh, Scotland.
    #6
    Hob,

    First and foremost call Apple. They will go through the jazz again with you and will let you know what to do from there, failing all the tests and repair stuff they suggest to you.

    Apple UK can be contacted by the following means.

    Good luck,

    cel
     
  7. Mord macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    UK
    #7
    get a refund and say the fault is intermitent
    the samething happened on my 600mhz ibook the ghraphics card is buggered beter to do it sooner rather than later

    buy a g4 ibook
     

Share This Page