*HELP* Iphone4 firmware not compatible error.

Discussion in 'Jailbreaks and iOS Hacks' started by tim040589, Aug 12, 2011.

  1. tim040589 macrumors newbie

    Aug 12, 2011
    I currently have my iphone under pwnd DFU mode.
    And when I try to restore it with Itune(version 10.4), it states "The iPhone "iPhone" could not be restored because the firmware file is not compatible.
    I downloaded iphone4 file from "http://www.felixbruns.de/iPod/firmware/" file "iPhone 4 (GSM) (4.3/8F190)".
    I wanted to downgrade to 4.3.3 from 4.3.5.
    Please help me~~
    Thank you,
  2. Fantasigraphic macrumors 65816

    Mar 25, 2009
    Because you need to d/l 4.3.3 (8J2) ipsw if trying to go back to 4.3.3.

    You have the iPhone 4 - 4.3(8F190) ipsw

    Go here to d/l the correct one:
  3. labman macrumors 604


    Jun 9, 2009
    Mich near Detroit
    I pretty sure we have told you a couple of times without shsh blobs you can not downgrade firmware. asking over and over only annoys people it won't get you downgraded.

Share This Page