Help! @-key not working

Discussion in 'macOS' started by Bertolt, Jan 14, 2007.

  1. Bertolt macrumors newbie

    Joined:
    Jan 14, 2007
    #1
    Hello everyone,

    my flatmate has the weirdest problem. On his Mac Mini G4 (Running 10.4.8), the @-Key doesn't work: Pressing alt-L does not produce an @ in any application. At first we thought that it was a hardware problem with his keyboard, but the bug occurs with every keyboard we've tried (including mine that correctly produces the @ on my mac). I searched the web and found nothing that could help; does anybody have an idea?

    Thanks,
    Bertolt.
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  3. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #3
    It's one of those keys that move around on different keyboard layouts. I have a dedicated @ key just above the right shift key... :)
     
  4. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #4
    You learn something new everyday.

    To the OP does the problem occur with a different user account?

    If you haven't tried can you create one, I think the OS/drivers have somehow got corrupted.
     
  5. TheAnswer macrumors 68030

    TheAnswer

    Joined:
    Jan 25, 2002
    Location:
    Orange County, CA
    #5
    OP, If you have the input menu (the little flag) activated in the right hand side on your menu bar select "Show Keyboard Viewer". You can then "Show keyboard viewer"...hold down your shift and option keys one at a time, then both together until you locate where the @ symbol is.

    If you do not have "Show Keyboard Viewer" as an option (or you don't have the input menu showing in the menu bar) go to Apple Menu > System Preferences > International then select the Input Menu tab. Then put a check in the box next to keyboard viewer and check the box Show input menu in menu bar at the bottom of the window. Also double check that your native keyboard layout is the one that is selected.

    Good Luck.
     

Share This Page