Help me get my Powerbook Working, OF problem

Discussion in 'PowerPC Macs' started by exilekiller, Jan 31, 2011.

  1. macrumors newbie

    Joined:
    Jan 31, 2011
    #1
    Ok, picked up a powerbook g4 a1106 a month ago bought some new parts for it and went to boot her up.

    Now I had a spare dmg image of leopard on an external hard drive I was going to try since I lost or misplaced the original disk somewhere.

    I boot it up and nothing happens. Just a white screen. So i tried the apple option O F at start up and it wont go into Open firmware.

    It just keeps giving me a white screen. I even tried resetting the PRAM.

    Please help me get this puppy working.

    Thanks
     
  2. macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #2
    When you say you had a spare DMG, do you mean just the DMG file?
    You can't restore from a DMG. You have to restore the DMG to a hard drive via disk utility or similar, then boot off of that image.
     
  3. thread starter macrumors newbie

    Joined:
    Jan 31, 2011
    #3
    how do i get to disk utility, I cant get into open firmware or anything
     
  4. macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #4
    You need to take the .DMG file and use Disk Utility on another Mac to create a Boot Disk for your Mac.
     
  5. thread starter macrumors newbie

    Joined:
    Jan 31, 2011
    #5
    ok if i was to get that bootable image would it just come up?

    I cant even get into open firmware, thats my main problem I think
     
  6. macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #6
    Once youve created an install DVD, hold C and it should "just come up" as long as the Mac is ok inside (This is the first step to a diagnosis if it is a hardware fault, which I doubt since its likely just the software thats missing).
     
  7. exilekiller, Jan 31, 2011
    Last edited: Jan 31, 2011

    thread starter macrumors newbie

    Joined:
    Jan 31, 2011
    #7

    I hope, if theres no software it is normal for it just be a white screen and no open firmware?
     
  8. macrumors 68000

    Joined:
    Feb 13, 2009
    Location:
    United Kingdom
    #8
    No, Its normal to go to a question mark on a grey screen, however what youre describing could also be achieved through a bodged OS X installation (At least the white screen) - although Open Firmwares background is white... so it may be half entering that instead, hence the need to get an OS X disc and try and get OS X working as it will show us where its bust/if its even working at all.
     
  9. thread starter macrumors newbie

    Joined:
    Jan 31, 2011
    #9
    alright, a friend is shipping me his disk of leopard, guess I will see and revive this thread in a few days
     

Share This Page