Help Me! Homesharing Problem after update

Discussion in 'Apple TV and Home Theater' started by mpossjr, Dec 11, 2012.

  1. macrumors member

    Joined:
    Nov 8, 2011
    Location:
    Georgia, USA
    #1
    I have an AppleTV 3 set up that worked great..... until I updated iTunes! Now when I try to watch a movie my homesharing connection drops about 5 times during a 2 hour movie. This only started after I updated iTunes to the latest version. Then I updated AppleTV to the latest version thinking that the update would solve the problem but it did not. My internet connection is fine and I can watch Netflix for hours with no problems. My PC does not sleep either. It just drops the movie and sends me back to the home screen where it says "turn on homesharing" then after about 10 seconds it shows my PC again and lets me resume the movie where I left off.
    Anyone else have the same problem? Anyone have a solution?
     
  2. macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #2
    Does it drop the same point each time e.g every 15 mins etc?

    I think the HDD is sleeping even though its being used via wfi and not waking
     
  3. thread starter macrumors member

    Joined:
    Nov 8, 2011
    Location:
    Georgia, USA
    #3
    It seems random but I'm not 100% sure.
    It was working fine with the same setup for a year until the iTunes update. The main purpose of this PC is to run iTunes for AppleTV.:confused:
     
  4. macrumors 68040

    MonkeySee....

    Joined:
    Sep 24, 2010
    Location:
    UK
    #4
    Same with mine. I had my drive to sleep after an hour and sure enough my ATV would disconnect after 1 hour. I've set my iMac to sleep after 3 hours now. Bit annoying and needs to be fixed.
     
  5. macrumors 68000

    JRoDDz

    Joined:
    Jul 2, 2009
    Location:
    NJ
    #5
    I am having this same exact issue where Apple TV2 will stop playing video and disconnect home sharing as soon as iMac goes to sleep (which is 10 minutes). Curiously, do you have your Mac's firewall enabled or disabled?
     
  6. thread starter macrumors member

    Joined:
    Nov 8, 2011
    Location:
    Georgia, USA
    #6
    I'm using an older Windows PC and it is set to never sleep. I have the Windows firewall disabled but I am using a firewall with my security software.
     
  7. macrumors 68000

    JRoDDz

    Joined:
    Jul 2, 2009
    Location:
    NJ
    #7
    Make sure your firewall is letting iTunes through. Or better yet, temporarily disable it to see if the problem goes away.
     
  8. thread starter macrumors member

    Joined:
    Nov 8, 2011
    Location:
    Georgia, USA
    #8
    Problem solved! I'm an idiot....
    I took your advice and checked to see if it actually was random and it was not. It was exactly 20 min apart. So this is obviously the computer going to sleep after 20. I check the computer and it was set to high performance and to not sleep at all! I looked through the other settings and somehow my HDD was set to sleep after 20 min! Derp. Changed that, fixed problem. I don't know how it was working before and suddenly not. Maybe it's time for a new "iTunes server"!? This POS windows vista has always given me problems.
     

Share This Page