Help me log into Apple Support Communities please!

Discussion in 'Mac Basics and Help' started by jaardesign, Oct 13, 2012.

  1. macrumors newbie

    Aug 23, 2010
    Hi, I am trying to log into the support forum on Apple's website but I can't. It is prompting me to create a username but I already have one!

    I go to, click on 'Support', click on 'Communities'. Then it takes me to a page that has me sign into my apple id. I click 'Sign in' and it brings me back to the same page but says, "Please sign in again. For added security, we need to reconfirm your Apple ID.". So, I fill out the ID and password and click 'Sign in' again. Now comes the problem part, it then takes me to a page titled, "Pick a username". I already have a user name, but if I enter it into the username field, it tells me, "This username is already taken, please choose another. Another has been provided." But, when I enter in another Username, it tells me, "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities.

    I have tried multiple browsers, IE, Safari, Firefox, Chrome and it does the same in all.
  2. macrumors newbie

    Nov 15, 2008
    I'm getting this as well. If I log into my Apple ID from anywhere other that the support forum, I can log in fine. Only the forum refuses.
  3. macrumors 68030


    Aug 10, 2010
    macrumors apparently
    you have to be initiated first, then blazed for a few months, then your password will work
  4. macrumors newbie

    Oct 29, 2012
    I have exactly the same problem!! It is really very annoying and obviously cannot seek support on the apple support site!
  5. macrumors newbie

    Aug 7, 2007
    Same here.
    log in everywhere else but discussions
  6. macrumors newbie

    Nov 1, 2012
    Help me log into Apple Support Communities please!

    same problem here. anyone have the answer?
  7. macrumors newbie

    Nov 1, 2012

    I tried logging in with my account and with my wife's account. I just end up on a page that says "An unknown error has occurred". It's really frustrating because I can't inform Apple of bugs they have in both iOS6 and iTunes 10.7, neither of which seem to have been posted elsewhere :-( Is there anybody out there who is able to post to Apple who could help me out?
  8. macrumors newbie

    Jun 20, 2010
    I am also unable to login to apple discussion. iTunes and App Store work just fine with my apple id. I get the "uknown error has occurred" message with discussion. This is really frustrating. Has anyone called apple? I'm going to when I get off work later tonight.
  9. ConvertApple, Nov 6, 2012
    Last edited: Nov 6, 2012

    macrumors newbie

    Oct 3, 2012
    Yes, I cannot log in either, it's been like this for weeks. I tried to create a new apple ID and even that wouldn't work. Given you need to use an apple id to use their products what on earth is going on?
  10. benjasmine, Nov 25, 2012
    Last edited: Nov 25, 2012

    macrumors newbie

    Nov 25, 2012
    I just found a solution that worked for me.

    When you are asked to login, instead of typing your e-mail address as your Apple ID, type your old username. If you don't remember having one, try guessing it.

    Credit goes to Siobhanish in Apple Support Communities. I had to log out of Apple Support Communities in order to view the post...

    If the solution doesn't work, view post #15 and #16 here:
  11. macrumors newbie

    Dec 15, 2012
    Im having the exact same issue, it is fine for me to log into iTunes and buys stuff, I can log into my apple ID section to see my devices and my details, but when trying to access support area of the i get asked to enter my log in details again for added security and then get a message that an unknown error has occured. Called apple support and they first said that " does not require a log in" and after I pointed out where the log in is the guy said "I would not even know where to begin to look for a solution". That says it all.

    I was a happy apple user for the last 6 years, but I am seriously getting fed up with the crap support, bad updates that bring a variety of bugs with them and hours spent trying to fix things that get messed up.

    Now I cannot even access to boards to look for solutions, because as someone else mentioned here even when I click on the link to the topic in Google it still asks me to log in and then promptly says that an unknown error has occurred.


    Oh, and unfortunately none of the solutions listed here helped me. Glad they worked for some of you though.
  12. macrumors newbie

    Feb 10, 2013
    NONE of this is working for me. I am fixing to scream.:mad:
  13. macrumors regular

    Sep 24, 2011
    Not sure if this will help, but have you tried deleting your browsers cookies, quitting the browser and trying again?

    Or use a different browser? I've had this problem and I seem to recall cleaning the cache and cookies fixed the problem. Still a stupid work around, but...
  14. macrumors 68020


    Apr 21, 2010
    I was having the same issue. I was trying to log in through Chrome and Firefox. I tried a few times in Safari after cleaning its cache, then I could get into the community forums.
  15. macrumors newbie

    Mar 12, 2013
    I cannot access Apple Support Communities anymore.

    If I enter my old username, I get this:

    "This username "xxxxxxx" is already taken, please choose another. Another has been provided."

    If I enter a random username, I get this:

    "An account utilizing this email address already exists. Only one account per email address is allowed on Apple Support Communities."

    Calling Apple Support on the phone has proven to be useless.

    Any suggestions?
  16. macrumors member

    Jan 2, 2014

    Saved my life, thanks! Turns out I had another account from 8 years ago, so I took a lucky guess and bam! logged in. I wonder if I can merge the two accounts now?
  17. macrumors newbie

    Oct 8, 2009

    I know my Apple ID (though Apple have made me change it far too many times).

    I know my Forums username.

    But I still can't log in.

    And as for trying to contact Apple...
  18. macrumors 601


    Feb 19, 2008
    The Finger Lakes Region
  19. macrumors regular


    Nov 10, 2007
    Bristol, UK
    Same here, get stuck in some useless loop asking me to check if I have multiple ID's - which I don't.

    Given up, ridiculous.
  20. macrumors 6502

    Mar 23, 2008
    AK, USA
    Try it now. I just signed in with no problems.
  21. macrumors 65816

    Oct 9, 2012
    A few weeks ago I had a different experience with ASC. I went to the ASC page and someone was signed in. I could see all of the users posts and whatever was there. No way for me to sign in of course.

    The next day it was back to normal.

    Sure glad Cook fired Forstall so the software part of the company is OK ;)
  22. macrumors regular


    Feb 7, 2012
    i went to apple support, and at some stage it was fixed, behind the scenes I suppose. but I had the issue for at least a year or two. i used feedback, and went through apple support and eventually it was handled.

Share This Page