help me not have to downgrade.

Discussion in 'Mac Programming' started by chris200x9, Oct 30, 2007.

  1. macrumors 6502a

    Joined:
    Jun 3, 2006
    #1
    Hi I have a problem every time I try to compile and run a command line c++ project in xcode 3 it just jumps and doesnt show the outpput window.


    I really need help I have a computer science midterm to do...and If i do not get this problem resolved in the next two hours I'll have to downgrade to tiger and use xcode 2.
     
  2. macrumors member

    Joined:
    Sep 29, 2007
    #2
    Why not just run gcc from a terminal? Especially since you seem to need to get this done soon.
     
  3. thread starter macrumors 6502a

    Joined:
    Jun 3, 2006
    #3
    I don't know how to?
     
  4. macrumors 6502

    hankolerd

    Joined:
    Sep 19, 2007
    Location:
    Seattle, WA
    #4
    there was another thread on here about people with that problem i think.

    i think what you are missing is when you are in Xcode 3.0, click on the run menu bar on the top of the screen, and select 'console' it is about 1/3rd down the list.:apple:
     
  5. thread starter macrumors 6502a

    Joined:
    Jun 3, 2006
    #5
    thank you so much

    I really hope apple fixes it, this is very annoying.
     
  6. macrumors 6502a

    Joined:
    Apr 11, 2007
    Location:
    Rocklin, CA
    #6
    Open Xcode Preferences. Select the Debugging tab. Change the value for On Start from Do Nothing to Show Console.
     
  7. macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #7
    You really should be able to use gcc on the terminal, you may well need to use it when you can't get your hands on Xcode or another IDE.
     

Share This Page