Help: My iPhone won't open up any apps!

Discussion in 'iPhone' started by tnisatard, Feb 3, 2009.

  1. macrumors 6502

    Joined:
    Apr 1, 2008
    #1
    I am on my iphone right now and all the apps i downloaded from iTunes refuse to open, I select an app and the loading screen shows up from the app, then it closes and goes back to my home screen

    If it matters I jailbroke and unlocked my iPhone and I'm currently running on tmobile I have also downloaded cracked apps and they work fine

    Thanks in advance, I turned offmy iphhone too and turns it back on and nothing changed
     
  2. macrumors 604

    jmann

    #2
    Put them on your computer, then delete them off your phone and resync them back.
     
  3. thread starter macrumors 6502

    Joined:
    Apr 1, 2008
    #3
    It's not on my comp, I don't sync my apps because iTunes deletes my cracked apps are there any alternatives
     
  4. macrumors 604

    jmann

    #4
    iTunes won't delete cracked apps. They sync over to the itunes library like regular apps.
     
  5. macrumors 68020

    Gix1k

    Joined:
    Jun 16, 2008
    #5
    Doubt it. Sounds like you need to do the whole thing over again. Restore, jailbreak, unlock. Sorry
     
  6. macrumors 68000

    Tokiopop

    Joined:
    Dec 6, 2008
    Location:
    West Yorkshire, UK
    #6
    Did you pay for these apps that wont open? :rolleyes:
     
  7. macrumors 604

    jmann

    #7
    Pretty clear ;)
     
  8. macrumors member

    Joined:
    Feb 5, 2009
    #8
    my phone does the same thing!!!....not jailbroken tho....might take it to the apple store if i cant figure it out.........1 month old.....
     
  9. macrumors 603

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #9
    If it's not jailbroken, try a reboot (slide to power off, wait, power back on, wait), and then install one new free app using iTunes and your iTunes account.
     
  10. Guest

    Joined:
    Sep 13, 2008
    #10
    You're being punished for stealing :).
     
  11. macrumors 6502a

    branjosef

    Joined:
    Oct 18, 2007
    Location:
    1.222.333.456
    #11
    maybe its closed for the holidays :D
     
  12. macrumors 68000

    deannnnn

    Joined:
    Jun 4, 2007
    Location:
    New York City & South Florida
    #12
    Press and hold the Power & Home buttons until the phone restarts.
     
  13. macrumors 6502a

    jmccullough108

    Joined:
    Nov 2, 2008
    Location:
    St. Louis, MO
    #13
    Buy the apps that you stole, and then try it again.
     
  14. macrumors 6502a

    Joined:
    Sep 18, 2006
    #14
    Make sure that your phone is properly configured with the iTunes account you purchased/downloaded the apps under.
     
  15. macrumors member

    Joined:
    Feb 5, 2009
    #15
    ^ .....it is the same account, the apps worked like 3 or 4 days ago. i also have already turned the phone on and off, as well as held the power button and the home button down simultaneously.......nothing changed.........:(
     
  16. macrumors regular

    Joined:
    Nov 29, 2008
    #16
    This happened to me when I first got my iphone. Someone here said to do the following and it worked. I forget the exact process but it goes:

    In Itunes click store/deauthorize computer. Then I think you shut down and restart itunes and then re-authorize computer. Then sync

    Let me know
     
  17. macrumors member

    Joined:
    Sep 28, 2007
    #17
    here is the fix

    delete ONE of the apps, go to appstore and redownload it and install.

    all your apps will work again
     
  18. macrumors newbie

    Joined:
    Nov 2, 2008
    #18
    Agreed, its a DRM issue (Digital Rights Management (I think))
    Either download a new app any free one will do or delete a present one and re download it.
    Once you do this all will be fine.
     
  19. macrumors member

    Joined:
    Feb 5, 2009
    #19
    nice....thanks guys, downloading another app fixed it......is that something that happens often? or is there no real way of knowing?......

    again thanks a bunch:D
     
  20. macrumors regular

    Joined:
    Oct 29, 2008
    #20
    delete and reinstall it? I think it might be something wrong happened when you sync with iTunes. It makes iTunes cant recognize these apps.
     
  21. macrumors newbie

    Joined:
    Apr 12, 2009
    #21
    Dont' Rejailbreak !!!

    DON'T LISTEN TO EVERYONE, DON'T REJAILBREAK AND REINSTALL

    hi, after a long battle to recover my stuff of my iphone (which failed)

    stupid apple, screw it and its dumb products (yes you heard me, apple sucks pc rules)

    god i lost EVERTHING just for trying to update from 2.2 to 2.2.1 THEN got caught in a restore loop making my iphone absolutely useless



    anyways took two days to fix it and now ran into your problem "app cannot be opened" even though they ALL transfered back to my iphone with no probs

    I found out how to fix it, the free app 'tap tap revenge' gave it away, on why it was screwed (sumthin on the lines of "your are not authorized on this computer to install this app"

    make sure your computer is authorized, EVEN if you authorized it previously

    redownload that app, THEN reinstall tap tap revenge

    THEN feel free to reinstall your apps again

    if you had brains like me dont' use installulous, you waste phone credits and also appulous IS installulous...use the web version so you can utilize your internet speed on your computer and once you download it you can burn a back up of your IPA

    i already have my ipas on my pc so its as easy as drag'n drop again:p
     
  22. macrumors 68040

    Joined:
    Feb 14, 2008
    #22
    Interesting. When I attempted to sync all of mine were deleted.
     
  23. macrumors regular

    Rusalka

    Joined:
    Dec 8, 2008
    Location:
    Northern Virginia
    #23
    Check your settings for Installous, mine transfer just fine
     

Share This Page