Help needed with Airport on 10.3, please.

Discussion in 'Mac Apps and Mac App Store' started by Samurai Jack, Nov 26, 2003.

  1. Samurai Jack macrumors newbie

    Joined:
    Oct 31, 2003
    Location:
    Hokkaido, Japan
    #1
    Hi
    I've been using my iMac (Airport Extreme card installed) as a software base station to provide wireless internet access to my wife on her iBook (Airport card installed). My iMac is connected to the internet through a DSL modem which is configured as the DHCP server. We have both been running 10.2, and there has been no problem.

    Last night I upgraded the iMac to 10.3 and my wife can nolonger access the internet over Airport. The airport network is available and the iBook can access the network no problem, but the iBook can not connect to the internet.

    I checked the network status on the iMac and it shows a green light for "built in ethernet", but an orange light for "Airport" saying that airport does not have an IP address and cannot access the internet.

    The iMac can access the internet no problem, and I have checked and double-checked that the Internet Sharing is turned on.

    Is this a compatibility issue with the DSL modem or something I can fix by configuring Airport properly.

    Thoughts anyone?
    Cheers.
     
  2. Golem macrumors 6502

    Joined:
    Jun 2, 2003
    Location:
    Sydney,Australia
    #2
    This is very similar to a problem I having I havent yet been able to find a solution,mainly from lack of time.

    I have a Cable modem sb 4200 connected to a netlink router and then downstairs into a Airport express.

    Now I can take the cable plugged into the airport and plug it in directly into the laptop and everything works.

    I plug it into the airport and I am on the airport network but not the internet.

    But I can plug the airport into a ISDN network at work and my laptop is on the network. So their is nothing wrong with the airport and my set up on the laptop.

    I presume the Cable modem isnt recognising the machine once to supply a dhcp address but that is a far as I have got.
     
  3. candan9019 macrumors regular

    Joined:
    Feb 18, 2003
    Location:
    Ontario-> Louisiana-> Colorado-> Ontario
    #3
    You may want to check the firewall. The settings may have changed, turn off the firewall in sharing to see if thats the problem (on the imac). Somethings like iChat need a port opened up in the firewall.
     
  4. Samurai Jack thread starter macrumors newbie

    Joined:
    Oct 31, 2003
    Location:
    Hokkaido, Japan
    #4
    I checked the firewall.

    I thought that might have been the case, as I had run into that problem with iChat myself. But no, the firewall is turned off.

    The built in ethernet is getting an IP address from the DSL modem, and the client iBook is getting an IP address from my iMac. Does the iMac need an IP address in the Airport network panel? Or is that a red herring as it were?
     
  5. hulugu macrumors 68000

    hulugu

    Joined:
    Aug 13, 2003
    Location:
    the faraway towns
    #5
    Odd problem

    I updated to OSX.3.1 last week and all my machines are connecting. But as I understand it, you're using the iMac as a base station so that rules out my set-up. Try setting the network IP to 10.0.1.1 and renewing the DHCP lease. This might kick the iMac into shape.
    My PB acted funny at first when I got OSX.3, but settled down after a few seconds.
     
  6. Samurai Jack thread starter macrumors newbie

    Joined:
    Oct 31, 2003
    Location:
    Hokkaido, Japan
    #6
    Solution - sort of

    As it happens I have a friend in Apple Japan, and I emailed him about this problem. He passed it on to the Apple Japan Engineers who immediately set about running their own tests. They found that there appears to be an issue when an OS 10.3 Mac trys to share an internet connection over airport to a 10.2 client. It simply doesn't work. The interim solution recommended is to upgrade the client to 10.3. In the meantime, Apple US engineers are now aware of the problem and are working on it.
    Thanks everyone for your help and comments and thanks also to Apple for picking this one up. I am so glad I have a Mac!!
     

Share This Page