help -- no sound output from WMVs

Discussion in 'Mac Apps and Mac App Store' started by 108, Dec 18, 2006.

  1. 108 macrumors member

    Joined:
    Sep 6, 2006
    Location:
    tokyo
    #1
    Hello! Perhaps this question was asked somewhere on these forums. I searched and just got more confused. I searched on Google and got a terrible headache.

    So. Here's my question.

    I have Flip4Mac for Quicktime. I can use it to run WMVs. Some WMVs play with sound. Others do not.

    I am very stupid about things like precise file formats or codecs or whatever. I read somewhere to make sure my midi sound output is at 48,000 -- I checked it, and it's just fine.

    So I don't know what's happening. All I know is that the sound should be working.

    The whole situation is very :(
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    What is the format of the audio tracks of the muted videos?
     
  3. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    You may need additional codecs you don't have. You might try Perian, although it's hard to say why things are not working without examples....
     
  4. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
  5. 108 thread starter macrumors member

    Joined:
    Sep 6, 2006
    Location:
    tokyo
    #5
    VLC doesn't even load the video.

    The error log says this:

    Code:
    main error: no suitable decoder module for fourcc `undf'.
    VLC probably does not support this sound or video format.
    main debug: killing decoder fourcc `undf', 0 PES in FIFO
    main debug: looking for decoder module: 25 candidates
    main error: no suitable decoder module for fourcc `WMV3'.
    VLC probably does not support this sound or video format.
     
  6. clevin macrumors G3

    clevin

    Joined:
    Aug 6, 2006
  7. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #7
    If this is a WMV 3 that requires WMP10 to play on a PC, you may ultimately have very limited success with anything on a Mac.

    If WMP9, Quicktime with Flip4Mac and Perian, and VLC 0.8.6 all fail to play it, I would say you are probably out of luck....
     
  8. 108 thread starter macrumors member

    Joined:
    Sep 6, 2006
    Location:
    tokyo
    #8
    gahhh, yeah, I just updated to VLC 0.8.6 and it now tells me

    Code:
    main error: no suitable decoder module for fourcc `wmas'.
    VLC probably does not support this sound or video format.
    Hmm. I guess I'll have to try something else . . . ?
     
  9. tkjazzer macrumors 6502

    Joined:
    Nov 30, 2004
    #9
    i have the same '.wmas' problem - could this be a DRM issue? My files play perfectly fine on wmp11 on parallels - just no audio on the mac side.
     

Share This Page