Help on my uni network connection

Discussion in 'Mac Help/Tips' started by Tenesmus, Dec 8, 2002.

  1. Tenesmus macrumors newbie

    Dec 8, 2002
    Chicago, IL
    Greetings all,

    Well this all started over a year ago. I had been at this school for about 1.5 years and had been delighted with the super fast network connection I got. At the time i was very into Diablo and Starcraft, and loved to play them over Then one day, I couldn't connect to anymore. All my PC using friends could without a hitch (which of course just strengthened their 'macs suck' philosophy) and I was left out. I was told by techs that they thought it was the university firewall blocking ports so I couldn't play, but they said that pcs and macs used the same ones, so I do not know how this can be. I have returned this year with hopes that with a fresh connection and achanged room my problems would be resolved, however they are the same. I have heard form other mac users that they experience the same problems, and have also found that whilst all the PC users in the dorms can use Kazaa I am completely unable to connect to any hosts via the Neo Kazaa shadow. I am desperate for a workaround as I still love starcraft and would greatly enjoy being able to play online once again. I have been back and forth since the fiasco started with the IT people, repeatedly getting "it should work now" and finding that nothing has changed. If anyone has any ideas of anything, dealing with the ports or otherwise I would be ever so grateful. Thanks in advance...
  2. evildead macrumors 65816


    Jun 18, 2001
    WestCost, USA
    do you have a firewall?

    Are you running any firwall on your Mac? Norton Personal Firewall, BrickHouse, or NetBarrier? What OS are you running?

    The ports you are using should not be effected by the fact that your running on a Mac. When you say that PC users in the Dorms can get in... do you mean PC users in your same dorm? At your same Uiversity?
  3. robbieduncan Moderator emeritus


    Jul 24, 2002

    Did you upgrade to Jaguar. It has a built in IP firewall. You might need to punch some holes in it for these programs.
  4. Tenesmus thread starter macrumors newbie

    Dec 8, 2002
    Chicago, IL
    The PC users are in the same dorm, and even the same room as me last year (which was really weird because we shared a port in the wall, using a Hub...) It has happened to me in os 9, 10.0, 10.1.x and also 10.2. I ran the "sudo ipfw list" command in terminal, and showed nothing being blocked, and also had a neighbor ping me, which also gave me no evidance of a firewall running locally on my machine. I just dont get this.

    Thanks to everyone who responded.
  5. peterjhill macrumors 65816


    Apr 25, 2002
    Seattle, WA
    Try this:

    Open a terminal window (you are running os x aren't you?)

    Type in:
    ifconfig -a

    If you are using a wired connection, see what your en0 connection says, if you are using wireless, check your en1 connection. For example, I am using wireless, and here is the results for me:
    [Titan:~] phill% ifconfig -a
    inet6 fe80::230:65ff:fe04:7b08%en1 prefixlen 64 scopeid 0x5
    inet netmask 0xffffff00 broadcast
    ether 00:30:65:04:7b:08
    media: autoselect status: active
    supported media: autoselect
    So you want to look at the line that begins with inet. My ip address is

    Next, type in 'su' and when asked enter the computers administrative password. Like this:
    [Titan:~] phill% su
    [Titan:/Users/phill] phill#

    See how the prompt changed, and now ends with a '#' This means you can now really fsck up your computer. So beware and be careful. Now you can do this:

    tcpdump -i <en0 for wired en1 for wireless> host <your ip address>
    [note: you can type control-c in the terminal window to stop the program]
    For example:
    [Titan:/Users/phill] phill# tcpdump -i en1 host
    tcpdump: listening on en1
    19:38:00.728255 > udp 4
    19:38:00.731034 > udp 97

    Now start up Starcraft. What is happening is that you are dumping packets that are destined to and from your computer. Ideally you would turn off your email app, and other network apps so you decrease the chatter.

    When you startup starcraft, the terminal window will log all the attempted connections to If you can't figure out what is up, either post the output of tcpdump, or email it directly to me and I will have a look

    My first guess is that they are doing a per-flow packet shaping and there are too many flows of outbound peer to peer apps that are squeezing your outbound flow to nothing.

    Note to all college students... Letting your dorm computer act as a Peer2Peer server allows people with cable modems to download your files and use up YOUR internet bandwidth. If your Internet connection is slow at your university, this is probably the reason. Students downloading files from other places is much less a problem.

    I know it might not be popular, but I see computers at work with 10,000 flows per 5 minutes from people downloading mp3s from one computer. That computer is getting 10000 times the bandwidth of the user with one connection to

Share This Page