1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Help! Pathetic USB performance on iMac G5

Discussion in 'PowerPC Macs' started by bigwig, Jan 1, 2010.

  1. macrumors 6502a

    #1
    I have an external USB hard drive (WD Elements 1.5TB) and an external DVD drive (LiteOn iHAS422-08 in a Vantec NST-530SU enclosure) hooked up to the USB ports on the back. I can't seem to get more than 5Mb/sec out of them. That's USB 1.1 level performance from these USB 2.0 devices, even though I have no USB 1.1 devices hooked up to the machine (other than the keyboard). Bluetooth is off. I've tried completely powering down but that didn't change anything. What could be the cause of this problem?

    iMac G5 Rev B
    2GHz PPC
    2 GB RAM
    OSX 10.5.8
     
  2. Guest

    spinnerlys

    #2
    USB 1.1 had a maximum transfer rate of 12Mbit/s, which would result in 1.5MB/s.

    The older PPC Macs don't have very good USB drivers, so the slow speed is expected, but that slow is a bit harsh.

    My iBook G4 could give me at least 10MB/s via USB 2.

    Have you tried resetting the SMU or another USB port on that iMac?
     
  3. macrumors 6502a

    #3
    How does one reset a USB port? I've tried different combinations of USB ports to no avail.
     
  4. Guest

    spinnerlys

    #4
    http://support.apple.com/kb/HT1767

    But I don't know if that will help, and can also be the external HDD controller that misbehaves.
     
  5. macrumors 6502a

    #5
    Resetting the SMU made no difference. Argh!
     

Share This Page