Help please: Can't hear through ear piece receiver

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Will514, Feb 13, 2008.

  1. macrumors newbie

    Joined:
    Oct 23, 2007
    #1
    Hi, I have a problem. I can't hear calls from my iPhone ear piece receiver. I can't hear people on incoming and outgoing calls and they can't hear me either. I can only hear them, and they hear me, if i put the phone on speaker phone. When i plug in the earphones i can hear calls fine but as soon as i take them out i can't hear anything and the same on the other end of the call. Has anyone out there ever have this problem?

    I don't know what happened. It was working fine. I've had my iPhone for about 5 months now. It's jailbroken and unlocked. I never had any problems before. The only thing i think i did that might have caused this is that i was showing a friend how normal headsets don't fit in the headset jack by inserting a jack into the phone then i put the phone on the dock and plugged in my stereo system through the dock to play music. While the phone was playing music, i received a call. I pulled the phone out of the dock and answered the call. I couldn't hear anything. That's when it started but i've played music through the dock many times on my stereo before and this has never happened.

    Please, if someone has a solution or has had this problem please let me know. It would be very much appreciated. Thank you for any information.

    - Will

    p.s. I forgot to mention that i "virginized" and restored my phone and re-jailbroke and re-unlocked my phone after this problem arose. no luck. still have the problem. so I think it might be a hard ware problem. this sucks.
     
  2. macrumors 68000

    Joined:
    Nov 3, 2007
    #2

    Insert and remove your headphones multiple times quickly. Odds are the iPhone isn't recognizing that your headphones are out. I had this happen and after fighting with it for a while I called Apple Support and that was thier official fix.
     
  3. macrumors member

    Joined:
    Aug 29, 2007
    #3
    Try rebooting the phone

    I had some issues with audio. Do a full reboot -- hold down the top button and the home button at the same time until you see the :apple: logo. This worked for me.
     
  4. thread starter macrumors newbie

    Joined:
    Oct 23, 2007
    #4
    Thank you so much!!!! It worked!!! Much appreciated! So thrilled! Awesome! Thanks again!
     
  5. macrumors newbie

    Joined:
    Aug 31, 2011
    #5
    Sound

    Try blowing the mesh on top and the ear piece port
     
  6. macrumors newbie

    Joined:
    Sep 29, 2011
    #6
    i too am having same issue on 3gs...cant believe it wot happened!
    it was just fine lately!

    tried ur fix mate..dint work!
     

Share This Page